summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2016-02-19 16:23:36 +0100
committerPieter Goetschalckx2016-02-19 16:23:36 +0100
commitd7fb614e0cb16f2ce9f4023d53ac18803d8bce9a (patch)
treecc8b78036638552a560bd41a2c262e77b72482cb /PKGBUILD
parent16012f745e7f75c5ff03ef50f5724ab5c625273c (diff)
downloadpackages-d7fb614e0cb16f2ce9f4023d53ac18803d8bce9a.tar.gz
packages-d7fb614e0cb16f2ce9f4023d53ac18803d8bce9a.tar.bz2
packages-d7fb614e0cb16f2ce9f4023d53ac18803d8bce9a.zip
Update for new release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 30 insertions, 47 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 782abf2..561b4a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
1# Maintainer: Ricardo Funke <ricardo [at] gmail [dot] com> 1# Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com>
2# Contributor: Ricardo Funke <ricardo [at] gmail [dot] com>
2# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> 3# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
3# Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> 4# Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com>
4# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch> 5# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
@@ -10,69 +11,51 @@
10# Contributor: petterk <stifler3k [at] hotmail [dot] com> 11# Contributor: petterk <stifler3k [at] hotmail [dot] com>
11 12
12pkgname=popcorntime-bin 13pkgname=popcorntime-bin
13pkgver=0.3.8.5 14_pkgname=popcorntime
14_pkgver='0.3.8-5' 15pkgver=0.3.9
15pkgrel=5 16pkgrel=1
16pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch." 17pkgdesc="Stream movies and TV shows from torrents"
17arch=('x86_64' 'i686') 18arch=('i686' 'x86_64')
18url="http://popcorntime.io/" 19url="https://popcorntime.sh"
19license=('GPL3') 20license=('GPL3')
20depends=('libnotify' 'desktop-file-utils' 'ttf-font' 'gconf' 'nss' 'libxtst' 'gtk2' 'alsa-lib') 21depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'desktop-file-utils')
21optdepends=('net-tools: necessary for the new vpn feature' 'ttf-liberation: open source ttf fonts') 22provides=('popcorntime' 'popcorn-time-ce')
22provides=('popcorntime')
23conflicts=('popcorntime') 23conflicts=('popcorntime')
24options=('!strip') 24options=('!strip')
25install="popcorntime.install" 25install=popcorntime.install
26sha1sums=('fcd6044861cfb78587d9b6e9590c0872144045c6' 26[ "$CARCH" = "i686" ] && _platform='Linux-32'
27 'd2e56426a321faabd316ea0bc89b2fa2fb0dfa48' 27[ "$CARCH" = "x86_64" ] && _platform='Linux-64'
28 '98cba5c0c979d37e601cc33cf3b562f106427d36') 28source=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-${_platform}.tar.xz"
29 "${_pkgname}.desktop")
30sha256sums=('27db5a11580204add3494f0274d170bad2fcba0c9e4461d408a20dcd10b4eadf'
31 '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
29 32
30_platform='Linux-64' 33[ "$CARCH" = "i686" ] && _platform=linux32
31 34[ "$CARCH" = "x86_64" ] && _platform=linux64
32if [ "$CARCH" = 'i686' ]; then
33 _platform='Linux-32'
34 sha1sums[0]='ec994d8a0420857018aabf8555926b0a6d43a1f1'
35fi
36
37#source=("http://get.popcorntime.io/build/Popcorn-Time-${_pkgver}-${_platform}.tar.xz"
38#source=("http://web.archive.org/web/20150909191012/http://get.popcorntime.io/build/Popcorn-Time-${_pkgver}-${_platform}.tar.xz"
39source=("http://web.archive.org/web/20150909184516/http://128.199.107.206/build/Popcorn-Time-${_pkgver}-${_platform}.tar.xz"
40 "popcorntime.install"
41 "popcorntime.desktop")
42 35
43package() { 36package() {
44 cd "${srcdir}" 37 _bpath="${_platform}"
45 38
46 install -dm755 "${pkgdir}/opt/${pkgname}/" 39 install -dm755 "${pkgdir}/usr/share/${_pkgname}"
47 install -dm755 "${pkgdir}/usr/bin" 40 install -dm755 "${pkgdir}/usr/bin"
48 install -dm755 "${pkgdir}/usr/share"
49 41
50 # Program 42 # Program
51 echo "${pkgdir}/opt/${pkgname}/" 43 install -Dm755 "${_bpath}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgname}/"
52 install -Dm755 "${srcdir}/Popcorn-Time" "${pkgdir}/opt/${pkgname}/" 44 install -Dm644 "${_bpath}/"{icudtl.dat,libffmpegsumo.so,nw.pak,package.json} \
53 install -Dm644 "${srcdir}/nw.pak" "${pkgdir}/opt/${pkgname}/" 45 "${pkgdir}/usr/share/${_pkgname}/"
54 install -Dm644 "${srcdir}/libffmpegsumo.so" "${pkgdir}/opt/${pkgname}/"
55# install -Dm644 "${srcdir}/CHANGELOG.md" "${pkgdir}/opt/${pkgname}/"
56 install -Dm644 "${srcdir}/icudtl.dat" "${pkgdir}/opt/${pkgname}/"
57 install -Dm644 "${srcdir}/install" "${pkgdir}/opt/${pkgname}/"
58# install -Dm644 "${srcdir}/LICENSE.txt" "${pkgdir}/opt/${pkgname}/"
59# install -Dm644 "${srcdir}/package.json" "${pkgdir}/opt/${pkgname}/"
60 install -Dm644 "${srcdir}/package.nw" "${pkgdir}/opt/${pkgname}/"
61 install -Dm644 "${srcdir}/popcorntime.png" "${pkgdir}/opt/${pkgname}/"
62# install -Dm644 "${srcdir}/README.md" "${pkgdir}/opt/${pkgname}/"
63 46
64 # Directories 47 # Directories
65 cp -a "${srcdir}/locales" "${pkgdir}/opt/${pkgname}/" 48 cp -a "${_bpath}/"{locales,node_modules,src} "${pkgdir}/usr/share/${_pkgname}/"
66# cp -a "${srcdir}/node_modules" "${pkgdir}/opt/${pkgname}/"
67# cp -a "${srcdir}/src" "${pkgdir}/opt/${pkgname}/"
68 49
69 # Link to program 50 # Link to program
70 ln -s "/opt/${pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/popcorntime" 51 ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}"
71 52
72 # Desktop file 53 # Desktop file
73 install -Dm644 "${srcdir}/popcorntime.desktop" "${pkgdir}/usr/share/applications/popcorntime.desktop" 54 install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
74 55
75 # Icon 56 # Icon
76 install -Dm644 "${srcdir}/popcorntime.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png" 57 install -Dm644 "${_bpath}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
77} 58}
78 59
60# vim:set ts=2 sw=2 et:
61