diff options
author | Kostis Karantias | 2018-12-16 21:09:39 +0200 |
---|---|---|
committer | Kostis Karantias | 2018-12-16 21:09:39 +0200 |
commit | 4d8b7a1f13f15555e79e48559dc719d9cc729ba0 (patch) | |
tree | 66cf098d6dd578864786841109ee3c58111dcebb /PKGBUILD | |
parent | 2bca99a4327fe051b31d5312787e5ed67bd6f3ec (diff) | |
download | packages-4d8b7a1f13f15555e79e48559dc719d9cc729ba0.tar.gz packages-4d8b7a1f13f15555e79e48559dc719d9cc729ba0.tar.bz2 packages-4d8b7a1f13f15555e79e48559dc719d9cc729ba0.zip |
Make this explicitly a CI build
* Rename with -ci-
* Build # as pkgrel and in URL so that our source urls are valid forever
* Include checksums
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 22 |
1 files changed, 10 insertions, 12 deletions
@@ -1,4 +1,5 @@ | |||
1 | # Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com> | 1 | # Maintainer: Kostis Karantias <kkarantias [at] gmail [dot] com> |
2 | # Contributor: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com> | ||
2 | # Contributor: Bastien Traverse <firstname at lastname dot email> | 3 | # Contributor: Bastien Traverse <firstname at lastname dot email> |
3 | # Contributor: Ricardo Funke <ricardo [at] gmail [dot] com> | 4 | # Contributor: Ricardo Funke <ricardo [at] gmail [dot] com> |
4 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> | 5 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> |
@@ -11,27 +12,24 @@ | |||
11 | # Contributor: xantares <xantares09 [at] hotmail [dot] com> | 12 | # Contributor: xantares <xantares09 [at] hotmail [dot] com> |
12 | # Contributor: petterk <stifler3k [at] hotmail [dot] com> | 13 | # Contributor: petterk <stifler3k [at] hotmail [dot] com> |
13 | 14 | ||
14 | pkgname=popcorntime-bin | 15 | pkgname=popcorntime-ci-bin |
15 | _pkgname=popcorntime | 16 | _pkgname=popcorntime |
16 | pkgver=0.3.10 | 17 | pkgver=0.3.10 |
17 | pkgrel=3 | 18 | pkgrel=362 |
18 | pkgdesc="Stream movies and TV shows from torrents (continuous integration builds)" | 19 | pkgdesc="Stream movies and TV shows from torrents (continuous integration builds)" |
19 | arch=('i686' 'x86_64') | 20 | arch=('i686' 'x86_64') |
20 | url="https://popcorntime.sh" | 21 | url="https://popcorntime.sh" |
21 | license=('GPL3') | 22 | license=('GPL3') |
22 | depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'desktop-file-utils') | 23 | depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'desktop-file-utils') |
23 | provides=('popcorntime' 'popcorn-time-ce') | 24 | provides=('popcorntime' 'popcorn-time-ce' 'popcorntime-bin') |
24 | conflicts=('popcorntime') | 25 | conflicts=('popcorntime') |
25 | options=('!strip') | 26 | options=('!strip') |
26 | source=("${_pkgname}.desktop") | 27 | source=("${_pkgname}.desktop") |
27 | ## Official releases are lagging behind. Using CI builds instead | 28 | source_i686=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/${pkgrel}/artifact/build/Popcorn-Time-${pkgver}_linux32.tar.xz") |
28 | #source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") | 29 | source_x86_64=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/${pkgrel}/artifact/build/Popcorn-Time-${pkgver}_linux64.tar.xz") |
29 | #source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") | 30 | sha512sums=('7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb') |
30 | source_i686=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux32.tar.xz") | 31 | sha512sums_i686=('5b6b9ba1232e6bdd3d7b8a949115d0020cf0fed9e2ed3d9d657c9c1a4230ec43ab25a7030d3dbc25b069ab6758bcc73bc659b8a232ad17a70cba7cb801bb374e') |
31 | source_x86_64=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux64.tar.xz") | 32 | sha512sums_x86_64=('4995da3263738fd9c99ad9158d13d768627a132253afe9f42d59c6ff6fc90d4ab1569b95b7c9f342b2a09145908af7baac0755d71542b1a5a98c0bbd80ff916a') |
32 | sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') | ||
33 | sha256sums_i686=('SKIP') | ||
34 | sha256sums_x86_64=('SKIP') | ||
35 | 33 | ||
36 | package() { | 34 | package() { |
37 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" | 35 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" |