summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKuklin István Alexander2022-06-19 20:22:20 +0200
committerKuklin István Alexander2022-06-19 20:22:20 +0200
commit445f1780bb7176e1e0daebf510a2f4bdca7ca5ba (patch)
treefa5bf1151237f87a62ba41671062cc972bfdc290 /PKGBUILD
parentedaf18ecc5c0e2ad53dfbd0b09334c3513de55df (diff)
downloadpackages-445f1780bb7176e1e0daebf510a2f4bdca7ca5ba.tar.gz
packages-445f1780bb7176e1e0daebf510a2f4bdca7ca5ba.tar.bz2
packages-445f1780bb7176e1e0daebf510a2f4bdca7ca5ba.zip
2.1.53
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b715267..af9fcb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
5 5
6# Maintainer: Kuklin István <kuklinistvan@zoho.com> 6# Maintainer: Kuklin István <kuklinistvan@zoho.com>
7pkgname=anki-official-binary-bundle 7pkgname=anki-official-binary-bundle
8pkgver=2.1.49 8pkgver=2.1.53
9pkgrel=1 9pkgrel=1
10epoch= 10epoch=
11pkgdesc="The official binary shipped with the tested versions of the dependent libraries." 11pkgdesc="The official binary shipped with the tested versions of the dependent libraries."
@@ -22,31 +22,25 @@ conflicts=('anki' 'anki-git')
22replaces=() 22replaces=()
23backup=() 23backup=()
24options=() 24options=()
25install= 25install=$pkgname.install
26changelog= 26changelog=
27topdirname="anki-$pkgver-linux" 27topdirname="anki-$pkgver-linux-qt6"
28source=( 28source=(
29 "https://github.com/ankitects/anki/releases/download/${pkgver}/${topdirname}.tar.bz2" 29 "https://github.com/ankitects/anki/releases/download/${pkgver}/${topdirname}.tar.zst"
30 "install_sh.patch" 30 "install_sh.patch"
31) 31)
32noextract=() 32noextract=()
33md5sums=('d0c13ae7cf988358fb231645f6490088' 33sha256sums=('c9739271c6f2bfbe248c98fd83d5ce8952301f21ac39f2c0504219294557ddfc'
34 '82d6fb7eb10ec0ae592093d89d8d5957') 34 '991297cb02434d753f55980205a22971ed98655b0f62f0104ae4692155355d8c')
35 35
36validpgpkeys=() 36validpgpkeys=()
37 37
38prepare() { 38prepare() {
39 cd "$srcdir" 39 cd "$srcdir"/"$topdirname"
40 ln -s "$topdirname" anki 40 patch install.sh ../install_sh.patch
41 patch -p0 -i install_sh.patch anki/install.sh
42 rm anki
43}
44
45build() {
46 cd "$topdirname"
47} 41}
48 42
49package() { 43package() {
50 cd "$topdirname" 44 cd "$topdirname"
51 PREFIX="$pkgdir"/usr/ ./install.sh 45 PREFIX="$pkgdir"/usr/ ./install.sh
52} 46}