summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-10-12 14:50:24 +0300
committerYigit Sever2021-10-12 14:50:24 +0300
commit251e4302251926d957ae1af8c5295bc011d81ed2 (patch)
treec94cf2d1f6904d6aa7b37e6be03b588cbcc35c5b /PKGBUILD
parent580f76e509d71336955dc31b6fcf5aec3937acd1 (diff)
downloadpackages-251e4302251926d957ae1af8c5295bc011d81ed2.tar.gz
packages-251e4302251926d957ae1af8c5295bc011d81ed2.tar.bz2
packages-251e4302251926d957ae1af8c5295bc011d81ed2.zip
Fix mimetype warning
This fixes the following warning; Wrong namespace on document element in '/usr/share/mime/packages/logisim-evolution.xml' (should be http://www.freedesktop.org/standards/shared-mime-info) Apparently https works for upstream: https://github.com/logisim-evolution/logisim-evolution/issues/678
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2961a12..2f17e86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
10 10
11pkgname=logisim-evolution 11pkgname=logisim-evolution
12pkgver=3.7.0 12pkgver=3.7.0
13pkgrel=1 13pkgrel=2
14pkgdesc='An educational tool for designing and simulating digital logic circuits (build from source)' 14pkgdesc='An educational tool for designing and simulating digital logic circuits (build from source)'
15provides=('logisim-evolution') 15provides=('logisim-evolution')
16conflicts=('logisim-evolution-git' 'logisim-evolution-bin') 16conflicts=('logisim-evolution-git' 'logisim-evolution-bin')
@@ -32,6 +32,11 @@ build() {
32 ./gradlew shadowJar 32 ./gradlew shadowJar
33} 33}
34 34
35prepare() {
36 cd "${srcdir}/${pkgname}-${pkgver}"
37 sed -i 's/https/http/' "support/Flatpak/com.github.reds.LogisimEvolution.xml"
38}
39
35package() { 40package() {
36 cd "${srcdir}/${pkgname}-${pkgver}" 41 cd "${srcdir}/${pkgname}-${pkgver}"
37 install -Dm644 "build/libs/logisim-evolution-${pkgver}-all.jar" \ 42 install -Dm644 "build/libs/logisim-evolution-${pkgver}-all.jar" \