summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-09-06 20:26:00 +0800
committerlilac2022-09-06 20:26:00 +0800
commitf6b814bb884dbfede25a34b6a402f1aae8384ab0 (patch)
tree5fa785512007cfc2a3280d7a24f724c79f029983
parent1cb8d4d8b94fe54d99f9625665c367cb6d3d3325 (diff)
downloadpackages-f6b814bb884dbfede25a34b6a402f1aae8384ab0.tar.gz
packages-f6b814bb884dbfede25a34b6a402f1aae8384ab0.tar.bz2
packages-f6b814bb884dbfede25a34b6a402f1aae8384ab0.zip
[lilac] updated to 0.3.13-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c9e230..2c663dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
1pkgbase = py-spy 1pkgbase = py-spy
2 pkgdesc = Sampling profiler for Python programs 2 pkgdesc = Sampling profiler for Python programs
3 pkgver = 0.3.12 3 pkgver = 0.3.13
4 pkgrel = 1 4 pkgrel = 2
5 url = https://github.com/benfred/py-spy 5 url = https://github.com/benfred/py-spy
6 arch = x86_64 6 arch = x86_64
7 license = GPL3 7 license = GPL3
8 makedepends = rust 8 makedepends = rust
9 makedepends = cargo 9 makedepends = cargo
10 makedepends = libunwind 10 makedepends = libunwind
11 source = https://files.pythonhosted.org/packages/source/p/py_spy/py_spy-0.3.12.tar.gz 11 source = https://github.com/benfred/py-spy/archive/refs/tags/v0.3.13.tar.gz
12 sha512sums = 4583de4ccfbb2db1a74a00c98ed90b2d1a5b57700ee00937bb18d3da8e9101b49480e558248acfcb03892158c74d4f6a1f965289070f6a4a8ad8ceda09e304cb 12 sha512sums = 83d4f76672002edf8189ed2917046cfea035c9e6a24b4e25eb04614340c361b459e44ec2edd658969a629743953791f880ce3728e93e732793e6815932d38838
13 13
14pkgname = py-spy 14pkgname = py-spy
diff --git a/PKGBUILD b/PKGBUILD
index 0ac8b16..02dca3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
1# Maintainer: lilydjwg <lilydjwg@gmail.com> 1# Maintainer: lilydjwg <lilydjwg@gmail.com>
2# Contributor: Clayton Craft <clayton@craftyguy.net> 2# Contributor: Clayton Craft <clayton@craftyguy.net>
3_name=py_spy
4pkgname=py-spy 3pkgname=py-spy
5pkgver=0.3.12 4pkgver=0.3.13
6pkgrel=1 5pkgrel=2
7pkgdesc="Sampling profiler for Python programs" 6pkgdesc="Sampling profiler for Python programs"
8arch=('x86_64') 7arch=('x86_64')
9license=('GPL3') 8license=('GPL3')
10url="https://github.com/benfred/py-spy" 9url="https://github.com/benfred/py-spy"
11makedepends=('rust' 'cargo' 'libunwind') 10makedepends=('rust' 'cargo' 'libunwind')
12source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz") 11source=("https://github.com/benfred/py-spy/archive/refs/tags/v${pkgver}.tar.gz")
13sha512sums=('4583de4ccfbb2db1a74a00c98ed90b2d1a5b57700ee00937bb18d3da8e9101b49480e558248acfcb03892158c74d4f6a1f965289070f6a4a8ad8ceda09e304cb') 12sha512sums=('83d4f76672002edf8189ed2917046cfea035c9e6a24b4e25eb04614340c361b459e44ec2edd658969a629743953791f880ce3728e93e732793e6815932d38838')
14 13
15build() { 14build() {
16 cd "${srcdir}/${_name}-${pkgver}" 15 cd "${srcdir}/${pkgname}-${pkgver}"
17 cargo build --release 16 cargo build --release
18} 17}
19 18
20package() { 19package() {
21 cd "${srcdir}/${_name}-${pkgver}" 20 cd "${srcdir}/${pkgname}-${pkgver}"
22 install -Dm755 "target/release/py-spy" "${pkgdir}/usr/bin/py-spy" 21 install -Dm755 "target/release/py-spy" "${pkgdir}/usr/bin/py-spy"
23 install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" 22 install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
24 install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md" 23 install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"