diff options
author | lilac | 2022-09-06 20:26:00 +0800 |
---|---|---|
committer | lilac | 2022-09-06 20:26:00 +0800 |
commit | f6b814bb884dbfede25a34b6a402f1aae8384ab0 (patch) | |
tree | 5fa785512007cfc2a3280d7a24f724c79f029983 | |
parent | 1cb8d4d8b94fe54d99f9625665c367cb6d3d3325 (diff) | |
download | packages-f6b814bb884dbfede25a34b6a402f1aae8384ab0.tar.gz packages-f6b814bb884dbfede25a34b6a402f1aae8384ab0.tar.bz2 packages-f6b814bb884dbfede25a34b6a402f1aae8384ab0.zip |
[lilac] updated to 0.3.13-2
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | PKGBUILD | 13 |
2 files changed, 10 insertions, 11 deletions
@@ -1,14 +1,14 @@ | |||
1 | pkgbase = py-spy | 1 | pkgbase = py-spy |
2 | pkgdesc = Sampling profiler for Python programs | 2 | pkgdesc = Sampling profiler for Python programs |
3 | pkgver = 0.3.12 | 3 | pkgver = 0.3.13 |
4 | pkgrel = 1 | 4 | pkgrel = 2 |
5 | url = https://github.com/benfred/py-spy | 5 | url = https://github.com/benfred/py-spy |
6 | arch = x86_64 | 6 | arch = x86_64 |
7 | license = GPL3 | 7 | license = GPL3 |
8 | makedepends = rust | 8 | makedepends = rust |
9 | makedepends = cargo | 9 | makedepends = cargo |
10 | makedepends = libunwind | 10 | makedepends = libunwind |
11 | source = https://files.pythonhosted.org/packages/source/p/py_spy/py_spy-0.3.12.tar.gz | 11 | source = https://github.com/benfred/py-spy/archive/refs/tags/v0.3.13.tar.gz |
12 | sha512sums = 4583de4ccfbb2db1a74a00c98ed90b2d1a5b57700ee00937bb18d3da8e9101b49480e558248acfcb03892158c74d4f6a1f965289070f6a4a8ad8ceda09e304cb | 12 | sha512sums = 83d4f76672002edf8189ed2917046cfea035c9e6a24b4e25eb04614340c361b459e44ec2edd658969a629743953791f880ce3728e93e732793e6815932d38838 |
13 | 13 | ||
14 | pkgname = py-spy | 14 | pkgname = py-spy |
@@ -1,24 +1,23 @@ | |||
1 | # Maintainer: lilydjwg <lilydjwg@gmail.com> | 1 | # Maintainer: lilydjwg <lilydjwg@gmail.com> |
2 | # Contributor: Clayton Craft <clayton@craftyguy.net> | 2 | # Contributor: Clayton Craft <clayton@craftyguy.net> |
3 | _name=py_spy | ||
4 | pkgname=py-spy | 3 | pkgname=py-spy |
5 | pkgver=0.3.12 | 4 | pkgver=0.3.13 |
6 | pkgrel=1 | 5 | pkgrel=2 |
7 | pkgdesc="Sampling profiler for Python programs" | 6 | pkgdesc="Sampling profiler for Python programs" |
8 | arch=('x86_64') | 7 | arch=('x86_64') |
9 | license=('GPL3') | 8 | license=('GPL3') |
10 | url="https://github.com/benfred/py-spy" | 9 | url="https://github.com/benfred/py-spy" |
11 | makedepends=('rust' 'cargo' 'libunwind') | 10 | makedepends=('rust' 'cargo' 'libunwind') |
12 | source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz") | 11 | source=("https://github.com/benfred/py-spy/archive/refs/tags/v${pkgver}.tar.gz") |
13 | sha512sums=('4583de4ccfbb2db1a74a00c98ed90b2d1a5b57700ee00937bb18d3da8e9101b49480e558248acfcb03892158c74d4f6a1f965289070f6a4a8ad8ceda09e304cb') | 12 | sha512sums=('83d4f76672002edf8189ed2917046cfea035c9e6a24b4e25eb04614340c361b459e44ec2edd658969a629743953791f880ce3728e93e732793e6815932d38838') |
14 | 13 | ||
15 | build() { | 14 | build() { |
16 | cd "${srcdir}/${_name}-${pkgver}" | 15 | cd "${srcdir}/${pkgname}-${pkgver}" |
17 | cargo build --release | 16 | cargo build --release |
18 | } | 17 | } |
19 | 18 | ||
20 | package() { | 19 | package() { |
21 | cd "${srcdir}/${_name}-${pkgver}" | 20 | cd "${srcdir}/${pkgname}-${pkgver}" |
22 | install -Dm755 "target/release/py-spy" "${pkgdir}/usr/bin/py-spy" | 21 | install -Dm755 "target/release/py-spy" "${pkgdir}/usr/bin/py-spy" |
23 | install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" | 22 | install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" |
24 | install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md" | 23 | install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md" |