diff options
author | Yigit Sever | 2024-07-05 16:35:58 +0300 |
---|---|---|
committer | Yigit Sever | 2024-07-05 16:35:58 +0300 |
commit | e616862c7bef33812ea84f809a00e83fe24078c3 (patch) | |
tree | 17f65f055dffcde57e1ba1f1669c46c98c45260b | |
parent | 32a13461618e213af6e59e0ec04e1e5ffdb82122 (diff) | |
download | packages-e616862c7bef33812ea84f809a00e83fe24078c3.tar.gz packages-e616862c7bef33812ea84f809a00e83fe24078c3.tar.bz2 packages-e616862c7bef33812ea84f809a00e83fe24078c3.zip |
Remove laying around serviio
-rw-r--r-- | PKGBUILD | 65 | ||||
-rw-r--r-- | README.md | 10 | ||||
-rw-r--r-- | serviio.desktop | 12 | ||||
-rw-r--r-- | serviio.install | 15 | ||||
-rw-r--r-- | serviio.png | bin | 1779 -> 0 bytes | |||
-rw-r--r-- | serviio.service | 9 | ||||
-rw-r--r-- | serviio.sh | 17 |
7 files changed, 0 insertions, 128 deletions
diff --git a/PKGBUILD b/PKGBUILD deleted file mode 100644 index eca3708..0000000 --- a/PKGBUILD +++ /dev/null | |||
@@ -1,65 +0,0 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: lesebas | ||
3 | # Contributor: Seb Deligny | ||
4 | pkgname=serviio | ||
5 | pkgver=2.4 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Free DLNA media server" | ||
8 | arch=('any') | ||
9 | url="http://www.serviio.org/" | ||
10 | license=('custom') | ||
11 | depends=('java-runtime-headless>=8' 'ffmpeg') | ||
12 | source=(http://download.serviio.org/releases/serviio-${pkgver}-linux.tar.gz | ||
13 | $pkgname.sh | ||
14 | $pkgname.service | ||
15 | $pkgname.desktop | ||
16 | $pkgname.png) | ||
17 | sha256sums=('b2c8b67ca6c0322cebe5e2c032783e1b6e6e8b7bfdf3308d5b3320eee2e019ab' | ||
18 | 'aacddfcde926bb7c9bbec59777b7c3ca44ef97a39258ef4033c34e83c69e9fe9' | ||
19 | '83d402a57ee31e48e70f9a8eb100468aaf1b0966974e9389fe4720e140cdc58d' | ||
20 | 'ecf69649d3a68521a4c751ba9a337143f06258228635e6d458a33271995cdec0' | ||
21 | '96f3fd953d77e5400714d9b20dc83d43ed43497afdeff43e58e273b3d3d87d1d') | ||
22 | |||
23 | package() { | ||
24 | cd "$pkgname-$pkgver" | ||
25 | |||
26 | # define variable for Serviio home directory | ||
27 | SERVIIO_HOME=$pkgdir/usr/share/java/$pkgname | ||
28 | |||
29 | # create the folders needed in the main directory | ||
30 | install -dm755 ${SERVIIO_HOME}/{config,lib,library,plugins} | ||
31 | |||
32 | # place the serviio scripts in the /usr/bin folder | ||
33 | install -Dm755 ${srcdir}/$pkgname.sh $pkgdir/usr/bin/$pkgname | ||
34 | install -Dm755 bin/$pkgname-console.sh $pkgdir/usr/bin/$pkgname-console | ||
35 | |||
36 | # copy xml config files to the config folder | ||
37 | install -m644 config/*.xml ${SERVIIO_HOME}/config | ||
38 | |||
39 | # copy all jar files to the lib folder | ||
40 | install -m644 lib/*.jar ${SERVIIO_HOME}/lib | ||
41 | |||
42 | # copy derby.properties to library folder | ||
43 | install -m644 library/derby.properties ${SERVIIO_HOME}/library | ||
44 | |||
45 | # copy plugins-readme.txt to plugins folder | ||
46 | install -m644 plugins/plugins-readme.txt ${SERVIIO_HOME}/plugins | ||
47 | |||
48 | # create the log folder in /var/log | ||
49 | install -dm755 $pkgdir/var/log/$pkgname | ||
50 | |||
51 | # create a symlink that puts all log files in /var/log | ||
52 | ln -s /var/log/$pkgname ${SERVIIO_HOME}/log | ||
53 | |||
54 | # supply the license file | ||
55 | install -Dm644 LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE | ||
56 | |||
57 | # install systemd-service | ||
58 | install -Dm644 "${srcdir}/$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service" | ||
59 | |||
60 | #install the .desktop file | ||
61 | install -Dm644 "${srcdir}/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" | ||
62 | |||
63 | #install the icon file | ||
64 | install -Dm644 "${srcdir}/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png" | ||
65 | } | ||
diff --git a/README.md b/README.md deleted file mode 100644 index 74be19f..0000000 --- a/README.md +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | # Archlinux Packages | ||
2 | PKGBUILDs of the packages I maintain at aur. | ||
3 | |||
4 | https://aur.archlinux.org/packages/?K=yigits&SeB=m | ||
5 | |||
6 | # aurpublish | ||
7 | |||
8 | On 2022-12-16 I switched to using [aurpublish](https://github.com/eli-schwartz/aurpublish/), it seems to have a problem with my old workflow, though. | ||
9 | |||
10 | [This workaround](https://github.com/eli-schwartz/aurpublish/issues/10#issuecomment-637884331) works, but it will clutter the git log with a bunch of deleted, re-added packages. | ||
diff --git a/serviio.desktop b/serviio.desktop deleted file mode 100644 index 1a62ec6..0000000 --- a/serviio.desktop +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | [Desktop Entry] | ||
2 | Version=1.0 | ||
3 | Type=Application | ||
4 | Name=Serviio | ||
5 | Comment[fr]=Console d'administration du serveur DLNA | ||
6 | Comment[en]=Administration console of DLNA server | ||
7 | Exec= serviio-console | ||
8 | Categories=AudioVideo | ||
9 | Icon=serviio | ||
10 | Path= | ||
11 | Terminal=false | ||
12 | StartupNotify=false | ||
diff --git a/serviio.install b/serviio.install deleted file mode 100644 index 043ea27..0000000 --- a/serviio.install +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | |||
2 | post_install() { | ||
3 | update-desktop-database -q | ||
4 | gtk-update-icon-cache -q -t -f usr/share/icons/hicolor | ||
5 | } | ||
6 | |||
7 | |||
8 | post_upgrade() { | ||
9 | gtk-update-icon-cache -q -t -f usr/share/icons/hicolor | ||
10 | } | ||
11 | |||
12 | post_remove() { | ||
13 | update-desktop-database -q | ||
14 | gtk-update-icon-cache -q -t -f usr/share/icons/hicolor | ||
15 | } \ No newline at end of file | ||
diff --git a/serviio.png b/serviio.png deleted file mode 100644 index f2eefad..0000000 --- a/serviio.png +++ /dev/null | |||
Binary files differ | |||
diff --git a/serviio.service b/serviio.service deleted file mode 100644 index 54e2855..0000000 --- a/serviio.service +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Serviio | ||
3 | After=network.target | ||
4 | |||
5 | [Service] | ||
6 | ExecStart=/usr/bin/serviio | ||
7 | |||
8 | [Install] | ||
9 | WantedBy=multi-user.target | ||
diff --git a/serviio.sh b/serviio.sh deleted file mode 100644 index 3293258..0000000 --- a/serviio.sh +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | #!/usr/bin/env bash | ||
2 | |||
3 | if [ "$(id -u)" -eq "0" ]; then | ||
4 | if [ -f /etc/profile.d/jdk.sh ]; then | ||
5 | . /etc/profile.d/jdk.sh | ||
6 | elif [ -f /etc/profile.d/jre.sh ]; then | ||
7 | . /etc/profile.d/jre.sh | ||
8 | fi | ||
9 | export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH | ||
10 | SERVIIO_HOME="/usr/share/java/serviio" | ||
11 | SERVIIO_CLASS_PATH="$SERVIIO_HOME/lib/*:$SERVIIO_HOME/config" | ||
12 | JAVA_OPTS="-Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Dderby.system.home=$SERVIIO_HOME/library -Dserviio.home=$SERVIIO_HOME -Dffmpeg.location=ffmpeg" | ||
13 | |||
14 | java -Xmx384M $JAVA_OPTS -classpath $SERVIIO_CLASS_PATH org.serviio.MediaServer "$@" | ||
15 | else | ||
16 | echo "Must be run as root." | ||
17 | fi | ||