diff options
author | Yigit Sever | 2024-07-17 16:20:36 +0300 |
---|---|---|
committer | Yigit Sever | 2024-07-17 16:20:36 +0300 |
commit | e0552e2b53216549db822204a32a745b4b93e02b (patch) | |
tree | 4e99618993530a8b96134a9887632d866e3fa833 | |
parent | 992ad3fa4d5115b695aa959ef93ae50d4ac1c549 (diff) | |
parent | 79e58419065678b492630da061df551d5994ec6f (diff) | |
download | packages-e0552e2b53216549db822204a32a745b4b93e02b.tar.gz packages-e0552e2b53216549db822204a32a745b4b93e02b.tar.bz2 packages-e0552e2b53216549db822204a32a745b4b93e02b.zip |
Add 'ryokucha/' from commit '79e58419065678b492630da061df551d5994ec6f'
git-subtree-dir: ryokucha
git-subtree-mainline: 992ad3fa4d5115b695aa959ef93ae50d4ac1c549
git-subtree-split: 79e58419065678b492630da061df551d5994ec6f
-rw-r--r-- | ryokucha/.SRCINFO | 15 | ||||
-rw-r--r-- | ryokucha/PKGBUILD | 22 |
2 files changed, 37 insertions, 0 deletions
diff --git a/ryokucha/.SRCINFO b/ryokucha/.SRCINFO new file mode 100644 index 0000000..69a4e10 --- /dev/null +++ b/ryokucha/.SRCINFO | |||
@@ -0,0 +1,15 @@ | |||
1 | pkgbase = ryokucha | ||
2 | pkgdesc = A GTK4 library that includes customized widgets | ||
3 | pkgver = 0.2.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/ryonakano/ryokucha | ||
6 | arch = x86_64 | ||
7 | license = LGPL3 | ||
8 | makedepends = meson | ||
9 | makedepends = vala | ||
10 | depends = gtk4 | ||
11 | depends = pango | ||
12 | source = ryokucha-0.2.0.tar.gz::https://github.com/ryonakano/ryokucha/archive/0.2.0.tar.gz | ||
13 | sha256sums = 40c038798cafd6f8f2de00b19a27b89042197a301b256b2afa8da35fcc21a2f6 | ||
14 | |||
15 | pkgname = ryokucha | ||
diff --git a/ryokucha/PKGBUILD b/ryokucha/PKGBUILD new file mode 100644 index 0000000..26bcd11 --- /dev/null +++ b/ryokucha/PKGBUILD | |||
@@ -0,0 +1,22 @@ | |||
1 | # Maintainer: Yigit Sever <yigit@yigitsever.com> | ||
2 | |||
3 | pkgname=ryokucha | ||
4 | pkgver=0.2.0 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="A GTK4 library that includes customized widgets" | ||
7 | arch=('x86_64') | ||
8 | url="https://github.com/ryonakano/ryokucha" | ||
9 | license=('LGPL3') | ||
10 | depends=('gtk4' 'pango') | ||
11 | makedepends=('meson' 'vala') | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
13 | sha256sums=('40c038798cafd6f8f2de00b19a27b89042197a301b256b2afa8da35fcc21a2f6') | ||
14 | |||
15 | build() { | ||
16 | arch-meson ${pkgname}-${pkgver} build | ||
17 | meson compile -C build | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | meson install -C build --destdir "${pkgdir}" | ||
22 | } | ||