summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2023-06-08 01:22:41 +0300
committerYigit Sever2023-06-08 01:22:41 +0300
commitdf0500feaed9c07b2333dd572da7347eedbcca09 (patch)
tree69efffa3e1bd19341ca045748bb26b7d0ac3cf08
parentfbdd3e4982185ff6730c14eed649ba3045b8568f (diff)
parentbbf7b84d51c8b78bdb462e17451fd106a41a1558 (diff)
downloadpackages-df0500feaed9c07b2333dd572da7347eedbcca09.tar.gz
packages-df0500feaed9c07b2333dd572da7347eedbcca09.tar.bz2
packages-df0500feaed9c07b2333dd572da7347eedbcca09.zip
Add 'unsilence/' from commit 'bbf7b84d51c8b78bdb462e17451fd106a41a1558'
git-subtree-dir: unsilence git-subtree-mainline: fbdd3e4982185ff6730c14eed649ba3045b8568f git-subtree-split: bbf7b84d51c8b78bdb462e17451fd106a41a1558
-rw-r--r--unsilence/.SRCINFO16
-rw-r--r--unsilence/.gitignore4
-rw-r--r--unsilence/PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/unsilence/.SRCINFO b/unsilence/.SRCINFO
new file mode 100644
index 0000000..63c4aa7
--- /dev/null
+++ b/unsilence/.SRCINFO
@@ -0,0 +1,16 @@
1pkgbase = unsilence
2 pkgdesc = Console Interface and Library to remove silent parts of a media file
3 pkgver = 1.0.9
4 pkgrel = 1
5 url = https://github.com/lagmoellertim/unsilence
6 arch = any
7 license = MIT
8 makedepends = python-setuptools
9 depends = ffmpeg
10 depends = python
11 depends = python-argparse
12 depends = python-rich
13 source = unsilence-1.0.9.tar.gz::https://github.com/lagmoellertim/unsilence/archive/1.0.9.tar.gz
14 sha256sums = 5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b
15
16pkgname = unsilence
diff --git a/unsilence/.gitignore b/unsilence/.gitignore
new file mode 100644
index 0000000..05c6d4d
--- /dev/null
+++ b/unsilence/.gitignore
@@ -0,0 +1,4 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
diff --git a/unsilence/PKGBUILD b/unsilence/PKGBUILD
new file mode 100644
index 0000000..72c1c80
--- /dev/null
+++ b/unsilence/PKGBUILD
@@ -0,0 +1,28 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname=unsilence
5pkgver=1.0.9
6pkgrel=1
7pkgdesc='Console Interface and Library to remove silent parts of a media file'
8arch=('any')
9url='https://github.com/lagmoellertim/unsilence'
10license=('MIT')
11depends=('ffmpeg' 'python' 'python-argparse' 'python-rich')
12makedepends=('python-setuptools')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
14sha256sums=('5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b')
15
16build() {
17 cd "${pkgname}-${pkgver}"
18 sed -i 's/10.10.0/12.6.0/' requirements.txt
19 python setup.py build
20}
21
22package() {
23 cd "${pkgname}-${pkgver}"
24 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
25 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
26 install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
27 rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples'
28}