summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Schrempf2020-05-06 13:18:14 +0200
committerDominik Schrempf2020-05-06 13:18:14 +0200
commitdd4b9c4a2b0e2e32ef6150c488f2ca8d14daf173 (patch)
tree7b5fdd5b575fe482e39d4ec98292922af66c5025
parent4dac7fef6478cd5f8f0446740297e9dd65933d47 (diff)
downloadpackages-dd4b9c4a2b0e2e32ef6150c488f2ca8d14daf173.tar.gz
packages-dd4b9c4a2b0e2e32ef6150c488f2ca8d14daf173.tar.bz2
packages-dd4b9c4a2b0e2e32ef6150c488f2ca8d14daf173.zip
patch pid file
-rw-r--r--.SRCINFO4
-rw-r--r--100-pidfile.patch11
-rw-r--r--PKGBUILD11
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0a3b4a..443ff96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
1pkgbase = htpdate 1pkgbase = htpdate
2 pkgdesc = A client for time synchronisation 2 pkgdesc = A client for time synchronisation
3 pkgver = 1.2.2 3 pkgver = 1.2.2
4 pkgrel = 2 4 pkgrel = 3
5 url = http://www.vervest.org/htp/ 5 url = http://www.vervest.org/htp/
6 arch = i686 6 arch = i686
7 arch = x86_64 7 arch = x86_64
@@ -9,8 +9,10 @@ pkgbase = htpdate
9 depends = glibc 9 depends = glibc
10 source = http://www.vervest.org/htp/archive/c/htpdate-1.2.2.tar.xz 10 source = http://www.vervest.org/htp/archive/c/htpdate-1.2.2.tar.xz
11 source = htpdate.service 11 source = htpdate.service
12 source = 100-pidfile.patch
12 md5sums = aad8c33933648532ac8716c809b15be1 13 md5sums = aad8c33933648532ac8716c809b15be1
13 md5sums = d00fce722a88150cffb1b322e6cc8869 14 md5sums = d00fce722a88150cffb1b322e6cc8869
15 md5sums = f4612bb44274ed571117724a49abb3c1
14 16
15pkgname = htpdate 17pkgname = htpdate
16 18
diff --git a/100-pidfile.patch b/100-pidfile.patch
new file mode 100644
index 0000000..a56aba4
--- /dev/null
+++ b/100-pidfile.patch
@@ -0,0 +1,11 @@
1--- htpdate.c 2019-07-12 19:10:17.000000000 +0200
2+++ htpdate.c.patched 2020-05-06 13:15:51.419075086 +0200
3@@ -499,7 +499,7 @@
4 printlog( 1, "Error writing pid file" );
5 exit(1);
6 } else {
7- fprintf( pid_file, "%u\n", (unsigned short)pid );
8+ fprintf( pid_file, "%d\n", (signed int)pid );
9 fclose( pid_file );
10 }
11 printlog( 0, "htpdate version "VERSION" started" );
diff --git a/PKGBUILD b/PKGBUILD
index 1ec24cd..ee6d7b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
3# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb> 3# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
4pkgname=htpdate 4pkgname=htpdate
5pkgver=1.2.2 5pkgver=1.2.2
6pkgrel=2 6pkgrel=3
7pkgdesc="A client for time synchronisation" 7pkgdesc="A client for time synchronisation"
8arch=(i686 x86_64) 8arch=(i686 x86_64)
9url="http://www.vervest.org/htp/" 9url="http://www.vervest.org/htp/"
@@ -12,14 +12,15 @@ depends=('glibc')
12# TODO: In the process of adding two patches from OpenWRT, but they are rejected. 12# TODO: In the process of adding two patches from OpenWRT, but they are rejected.
13# See https://aur.archlinux.org/packages/htpdate/. 13# See https://aur.archlinux.org/packages/htpdate/.
14source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz" 14source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz"
15 "htpdate.service") 15 "htpdate.service"
16 "100-pidfile.patch")
16md5sums=('aad8c33933648532ac8716c809b15be1' 17md5sums=('aad8c33933648532ac8716c809b15be1'
17 'd00fce722a88150cffb1b322e6cc8869') 18 'd00fce722a88150cffb1b322e6cc8869'
18 # "100-adjtimex.patch" 19 'f4612bb44274ed571117724a49abb3c1')
19 # "101-daemon-run-in-foreground.patch")
20 20
21build() { 21build() {
22 cd ${pkgname}-${pkgver} 22 cd ${pkgname}-${pkgver}
23 patch htpdate.c 100-pidfile.patch
23 make 24 make
24} 25}
25 26