summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2023-01-06 15:56:02 +0300
committerYigit Sever2023-01-06 15:56:02 +0300
commitdb1db904b20b1ea8328d548a4dd804e41bf1cfaf (patch)
treec2a621bd2a6c075f28b328dae345a05fdc477fb7
parent6c577844b8fc87f4977eee9f30a371083e22d03c (diff)
parent091fb97d4114670b1c6a45efe1ee6c17b3f5061e (diff)
downloadpackages-db1db904b20b1ea8328d548a4dd804e41bf1cfaf.tar.gz
packages-db1db904b20b1ea8328d548a4dd804e41bf1cfaf.tar.bz2
packages-db1db904b20b1ea8328d548a4dd804e41bf1cfaf.zip
Initial upload: gau 2.1.2-1
Merge remote-tracking branch 'origin'
-rw-r--r--.SRCINFO13
-rw-r--r--gau/.SRCINFO13
-rw-r--r--gau/.gitignore4
-rw-r--r--gau/PKGBUILD31
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..103f069
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
1pkgbase = gau
2 pkgdesc = Fetch known URLs from AlienVault's Open Threat Exchange, the Wayback Machine, and Common Crawl
3 pkgver = 2.0.8
4 pkgrel = 1
5 url = https://github.com/lc/gau
6 arch = any
7 license = MIT
8 makedepends = go
9 depends = glibc
10 source = gau-2.0.8.tar.gz::https://github.com/lc/gau/archive/v2.0.8.tar.gz
11 sha256sums = 9604f0b7bf258547778a155afd2c58d32eeeb82d3bcbcbe97616ccefd1287d9a
12
13pkgname = gau
diff --git a/gau/.SRCINFO b/gau/.SRCINFO
new file mode 100644
index 0000000..1e4238e
--- /dev/null
+++ b/gau/.SRCINFO
@@ -0,0 +1,13 @@
1pkgbase = gau
2 pkgdesc = Fetch known URLs from AlienVault's Open Threat Exchange, the Wayback Machine, and Common Crawl
3 pkgver = 2.1.2
4 pkgrel = 1
5 url = https://github.com/lc/gau
6 arch = any
7 license = MIT
8 makedepends = go
9 depends = glibc
10 source = gau-2.1.2.tar.gz::https://github.com/lc/gau/archive/v2.1.2.tar.gz
11 sha256sums = 2900ba86dfda01b5d8a90e1547f158feb134f6d2b757ff8fc77d96d290f72e4c
12
13pkgname = gau
diff --git a/gau/.gitignore b/gau/.gitignore
new file mode 100644
index 0000000..05c6d4d
--- /dev/null
+++ b/gau/.gitignore
@@ -0,0 +1,4 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
diff --git a/gau/PKGBUILD b/gau/PKGBUILD
new file mode 100644
index 0000000..09b6dfd
--- /dev/null
+++ b/gau/PKGBUILD
@@ -0,0 +1,31 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: <contact@amadejpapez.com>
3
4pkgname=gau
5pkgver=2.1.2
6pkgrel=1
7pkgdesc="Fetch known URLs from AlienVault's Open Threat Exchange, the Wayback Machine, and Common Crawl"
8arch=(any)
9url='https://github.com/lc/gau'
10license=(MIT)
11depends=(glibc)
12makedepends=(go)
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
14sha256sums=('2900ba86dfda01b5d8a90e1547f158feb134f6d2b757ff8fc77d96d290f72e4c')
15
16build() {
17 export CGO_CPPFLAGS="${CPPFLAGS}"
18 export CGO_CFLAGS="${CFLAGS}"
19 export CGO_CXXFLAGS="${CXXFLAGS}"
20 export CGO_LDFLAGS="${LDFLAGS}"
21 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
22
23 cd "${pkgname}-${pkgver}/cmd/gau"
24 go build -v -o "${pkgname}" .
25}
26
27package() {
28 cd "${pkgname}-${pkgver}"
29 install -Dvm755 "cmd/gau/gau" -t "${pkgdir}/usr/bin"
30 install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
31}