summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2023-05-12 15:46:27 +0300
committerYigit Sever2023-05-12 15:46:27 +0300
commit6ba162019a2e295ccba3c0baeb58b19e1ce029aa (patch)
tree141b51f28739636c4ad1ccd51a0dcedcd82b3e74
parentcf79f2c70d17e19f35d65023ce12dfe3ffb6f21b (diff)
downloadpackages-6ba162019a2e295ccba3c0baeb58b19e1ce029aa.tar.gz
packages-6ba162019a2e295ccba3c0baeb58b19e1ce029aa.tar.bz2
packages-6ba162019a2e295ccba3c0baeb58b19e1ce029aa.zip
Deleted package: unsilence
-rw-r--r--unsilence/.SRCINFO16
-rw-r--r--unsilence/.gitignore4
-rw-r--r--unsilence/PKGBUILD28
3 files changed, 0 insertions, 48 deletions
diff --git a/unsilence/.SRCINFO b/unsilence/.SRCINFO
deleted file mode 100644
index 63c4aa7..0000000
--- a/unsilence/.SRCINFO
+++ /dev/null
@@ -1,16 +0,0 @@
1pkgbase = unsilence
2 pkgdesc = Console Interface and Library to remove silent parts of a media file
3 pkgver = 1.0.9
4 pkgrel = 1
5 url = https://github.com/lagmoellertim/unsilence
6 arch = any
7 license = MIT
8 makedepends = python-setuptools
9 depends = ffmpeg
10 depends = python
11 depends = python-argparse
12 depends = python-rich
13 source = unsilence-1.0.9.tar.gz::https://github.com/lagmoellertim/unsilence/archive/1.0.9.tar.gz
14 sha256sums = 5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b
15
16pkgname = unsilence
diff --git a/unsilence/.gitignore b/unsilence/.gitignore
deleted file mode 100644
index 05c6d4d..0000000
--- a/unsilence/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
diff --git a/unsilence/PKGBUILD b/unsilence/PKGBUILD
deleted file mode 100644
index 72c1c80..0000000
--- a/unsilence/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname=unsilence
5pkgver=1.0.9
6pkgrel=1
7pkgdesc='Console Interface and Library to remove silent parts of a media file'
8arch=('any')
9url='https://github.com/lagmoellertim/unsilence'
10license=('MIT')
11depends=('ffmpeg' 'python' 'python-argparse' 'python-rich')
12makedepends=('python-setuptools')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
14sha256sums=('5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b')
15
16build() {
17 cd "${pkgname}-${pkgver}"
18 sed -i 's/10.10.0/12.6.0/' requirements.txt
19 python setup.py build
20}
21
22package() {
23 cd "${pkgname}-${pkgver}"
24 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
25 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
26 install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
27 rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples'
28}