summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2016-08-10 11:26:05 +0200
committerPieter Goetschalckx2016-08-10 11:26:05 +0200
commit65f8d3ad3d184fcf348457a4043f78de86088c70 (patch)
tree81a596054f45cd1b735e27c2e657f2bee090e948
parent15eb232ed54452a272c79a7c0dbf0dbefa05a0d9 (diff)
downloadpackages-65f8d3ad3d184fcf348457a4043f78de86088c70.tar.gz
packages-65f8d3ad3d184fcf348457a4043f78de86088c70.tar.bz2
packages-65f8d3ad3d184fcf348457a4043f78de86088c70.zip
Remove .install file (handled by package hooks)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--popcorntime.install14
3 files changed, 6 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07b6977..06253df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
1pkgbase = popcorntime-bin 1pkgbase = popcorntime-bin
2 pkgdesc = Stream movies and TV shows from torrents 2 pkgdesc = Stream movies and TV shows from torrents
3 pkgver = 0.3.9 3 pkgver = 0.3.9
4 pkgrel = 6 4 pkgrel = 7
5 url = https://popcorntime.sh 5 url = https://popcorntime.sh
6 install = popcorntime.install
7 arch = i686 6 arch = i686
8 arch = x86_64 7 arch = x86_64
9 license = GPL3 8 license = GPL3
@@ -22,9 +21,9 @@ pkgbase = popcorntime-bin
22 source = popcorntime.desktop 21 source = popcorntime.desktop
23 sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334 22 sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334
24 source_i686 = https://get.popcorntime.sh/build/Popcorn-Time-0.3.9-Linux-32.tar.xz 23 source_i686 = https://get.popcorntime.sh/build/Popcorn-Time-0.3.9-Linux-32.tar.xz
25 sha256sums_i686 = SKIP 24 sha256sums_i686 = 0c8a84e853946c70b4986d8044ec869f995b8001b48cd5bd3ef0ed61e8848335
26 source_x86_64 = https://get.popcorntime.sh/build/Popcorn-Time-0.3.9-Linux-64.tar.xz 25 source_x86_64 = https://get.popcorntime.sh/build/Popcorn-Time-0.3.9-Linux-64.tar.xz
27 sha256sums_x86_64 = SKIP 26 sha256sums_x86_64 = 5655111b7f5883ce7a620a8fb0b9f7fb7563a46516697aac5ad2b28b8b5e49df
28 27
29pkgname = popcorntime-bin 28pkgname = popcorntime-bin
30 29
diff --git a/PKGBUILD b/PKGBUILD
index f818aa1..f7310e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
13pkgname=popcorntime-bin 13pkgname=popcorntime-bin
14_pkgname=popcorntime 14_pkgname=popcorntime
15pkgver=0.3.9 15pkgver=0.3.9
16pkgrel=6 16pkgrel=7
17pkgdesc="Stream movies and TV shows from torrents" 17pkgdesc="Stream movies and TV shows from torrents"
18arch=('i686' 'x86_64') 18arch=('i686' 'x86_64')
19url="https://popcorntime.sh" 19url="https://popcorntime.sh"
@@ -22,13 +22,12 @@ depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'deskt
22provides=('popcorntime' 'popcorn-time-ce') 22provides=('popcorntime' 'popcorn-time-ce')
23conflicts=('popcorntime') 23conflicts=('popcorntime')
24options=('!strip') 24options=('!strip')
25install=popcorntime.install
26source=("${_pkgname}.desktop") 25source=("${_pkgname}.desktop")
27source_i686=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz") 26source_i686=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz")
28source_x86_64=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz") 27source_x86_64=("https://get.popcorntime.sh/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz")
29sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') 28sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
30sha256sums_i686=('SKIP') 29sha256sums_i686=('0c8a84e853946c70b4986d8044ec869f995b8001b48cd5bd3ef0ed61e8848335')
31sha256sums_x86_64=('SKIP') 30sha256sums_x86_64=('5655111b7f5883ce7a620a8fb0b9f7fb7563a46516697aac5ad2b28b8b5e49df')
32 31
33[ "$CARCH" = "i686" ] && _platform=linux32 32[ "$CARCH" = "i686" ] && _platform=linux32
34[ "$CARCH" = "x86_64" ] && _platform=linux64 33[ "$CARCH" = "x86_64" ] && _platform=linux64
@@ -57,5 +56,3 @@ package() {
57 install -Dm644 "${_bpath}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png" 56 install -Dm644 "${_bpath}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
58} 57}
59 58
60# vim:set ts=2 sw=2 et:
61
diff --git a/popcorntime.install b/popcorntime.install
deleted file mode 100644
index 380b52e..0000000
--- a/popcorntime.install
+++ /dev/null
@@ -1,14 +0,0 @@
1post_install() {
2 update-desktop-database -q
3 echo
4 echo "WARNING: Popcorn Time streams movies from Torrents"
5 echo "Downloading copyrighted material may be illegal in your country!"
6 echo "Use at your own risk!"
7 echo
8}
9
10post_upgrade() {
11 post_install
12}
13
14# vim:set ts=2 sw=2 et: