diff options
author | Yigit Sever | 2021-11-16 15:56:06 +0300 |
---|---|---|
committer | Yigit Sever | 2021-11-16 15:56:06 +0300 |
commit | 644666a1364d32020cd14c0d54356a57be6f9601 (patch) | |
tree | 23182e600cec1b9d945af94de81292a2f61bd632 | |
download | packages-644666a1364d32020cd14c0d54356a57be6f9601.tar.gz packages-644666a1364d32020cd14c0d54356a57be6f9601.tar.bz2 packages-644666a1364d32020cd14c0d54356a57be6f9601.zip |
Tracking adopted packages
- dvc
- flowy
- ouch{-bin, -git,}
-rw-r--r-- | .SRCINFO | 14 | ||||
-rw-r--r-- | PKGBUILD | 45 |
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO new file mode 100644 index 0000000..37e0570 --- /dev/null +++ b/.SRCINFO | |||
@@ -0,0 +1,14 @@ | |||
1 | pkgbase = ouch | ||
2 | pkgdesc = Painless compression and decompression in the terminal | ||
3 | pkgver = 0.3.1 | ||
4 | pkgrel = 3 | ||
5 | url = https://github.com/ouch-org/ouch | ||
6 | arch = x86_64 | ||
7 | license = MIT | ||
8 | makedepends = cargo | ||
9 | conflicts = ouch-git | ||
10 | conflicts = ouch-bin | ||
11 | source = ouch-0.3.1.tar.gz::https://github.com/ouch-org/ouch/archive/0.3.1.tar.gz | ||
12 | sha256sums = 269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d | ||
13 | |||
14 | pkgname = ouch | ||
diff --git a/PKGBUILD b/PKGBUILD new file mode 100644 index 0000000..5d3f5fa --- /dev/null +++ b/PKGBUILD | |||
@@ -0,0 +1,45 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=ouch | ||
4 | pkgver=0.3.1 | ||
5 | pkgrel=3 | ||
6 | pkgdesc="Painless compression and decompression in the terminal" | ||
7 | arch=('x86_64') | ||
8 | url="https://github.com/ouch-org/ouch" | ||
9 | license=('MIT') | ||
10 | makedepends=('cargo') | ||
11 | conflicts=(${pkgname}-git ${pkgname}-bin) | ||
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
13 | sha256sums=('269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d') | ||
14 | |||
15 | prepare() { | ||
16 | cd "$srcdir/$pkgname-$pkgver" | ||
17 | cargo fetch --locked --target "$CARCH-unknown-linux-gnu" | ||
18 | } | ||
19 | |||
20 | build() { | ||
21 | cd "$srcdir/$pkgname-$pkgver" | ||
22 | export RUSTUP_TOOLCHAIN=stable | ||
23 | export CARGO_TARGET_DIR=target | ||
24 | GEN_COMPLETIONS=1 cargo build --frozen --release --all-features | ||
25 | } | ||
26 | |||
27 | check() { | ||
28 | cd "$srcdir/$pkgname-$pkgver" | ||
29 | export RUSTUP_TOOLCHAIN=stable | ||
30 | cargo test --frozen --all-features | ||
31 | } | ||
32 | |||
33 | package() { | ||
34 | cd "$srcdir/$pkgname-$pkgver" | ||
35 | |||
36 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname" | ||
37 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
38 | |||
39 | cd target/release/build/ouch-*/out/completions | ||
40 | sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch | ||
41 | |||
42 | install -Dm0644 ${pkgname}.bash "${pkgdir}/usr/share/bash-completion/completions/${pkgname}" | ||
43 | install -Dm0644 ${pkgname}.fish "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish" | ||
44 | install -Dm0644 _${pkgname} "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}" | ||
45 | } | ||