summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranck STAUFFER2021-01-16 10:12:47 +0100
committerFranck STAUFFER2021-01-16 10:12:47 +0100
commit3bde922c40e071bd3202a0ca3662b753529deab2 (patch)
treea7d1abd2e14de2a2e66f910deb2d5a2514f2a55f
parent21f3ea609d45acbc278c8a8ce349150d1dd55eeb (diff)
downloadpackages-3bde922c40e071bd3202a0ca3662b753529deab2.tar.gz
packages-3bde922c40e071bd3202a0ca3662b753529deab2.tar.bz2
packages-3bde922c40e071bd3202a0ca3662b753529deab2.zip
Add LICENSE
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a6c82c..2851dd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
1pkgbase = pfetch 1pkgbase = pfetch
2 pkgdesc = A pretty system information tool written in POSIX sh. 2 pkgdesc = A pretty system information tool written in POSIX sh.
3 pkgver = 0.6.0 3 pkgver = 0.6.0
4 pkgrel = 1 4 pkgrel = 2
5 url = https://github.com/dylanaraps/pfetch 5 url = https://github.com/dylanaraps/pfetch
6 arch = any 6 arch = any
7 license = MIT 7 license = MIT
8 provides = pfetch 8 provides = pfetch
9 conflicts = pfetch-git
9 source = pfetch-0.6.0.tar.gz::https://github.com/dylanaraps/pfetch/archive/0.6.0.tar.gz 10 source = pfetch-0.6.0.tar.gz::https://github.com/dylanaraps/pfetch/archive/0.6.0.tar.gz
10 sha1sums = 9440d085e9ef93a94127ed634edbbfb2048186c7 11 b2sums = 300f6f44f9306df4f438227a6f35bd54f50e477b950a45d63656f7c460cfc30a8b44ebdb3d5fdcf1e808e3b8e8e69e14088ff73a5da4485abf694893f2cc53f3
11 12
12pkgname = pfetch 13pkgname = pfetch
13 14
diff --git a/PKGBUILD b/PKGBUILD
index 4dbc1f7..9506dfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
1# Maintainer: Caio Novais <caionov08 at gmail dot com> 1# Maintainer: Franck STAUFFER <franck.stauffer@monaco.mc>
2# shellcheck shell=bash 2# Contributor: Caio Novais <caionov08 at gmail dot com>
3# shellcheck disable=SC2034,SC2154 3
4pkgname=pfetch 4pkgname=pfetch
5pkgver=0.6.0 5pkgver=0.6.0
6pkgrel=1 6pkgrel=2
7pkgdesc="A pretty system information tool written in POSIX sh." 7pkgdesc="A pretty system information tool written in POSIX sh."
8arch=('any') 8arch=('any')
9url="https://github.com/dylanaraps/$pkgname" 9url="https://github.com/dylanaraps/$pkgname"
10license=('MIT') 10license=('MIT')
11provides=("$pkgname") 11provides=("$pkgname")
12source=("$pkgname-$pkgver.tar.gz::https://github.com/dylanaraps/$pkgname/archive/$pkgver.tar.gz") 12conflicts=('pfetch-git')
13sha1sums=('9440d085e9ef93a94127ed634edbbfb2048186c7') 13source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
14b2sums=('300f6f44f9306df4f438227a6f35bd54f50e477b950a45d63656f7c460cfc30a8b44ebdb3d5fdcf1e808e3b8e8e69e14088ff73a5da4485abf694893f2cc53f3')
14 15
15package() { 16package() {
16 install -Dm755 "$srcdir/$pkgname-$pkgver/pfetch" "$pkgdir/usr/bin/pfetch" 17 install -Dm755 "$srcdir/$pkgname-$pkgver/pfetch" "$pkgdir/usr/bin/pfetch"
18 install -Dm755 "$srcdir/$pkgname-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
17} 19}