summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2024-10-09 17:03:44 +0200
committerYigit Sever2024-10-09 17:03:44 +0200
commit326080dad9007eda7ddba7ffb3de19b302fe49bb (patch)
tree4660da4ce8b3e57797538bdfec574db5112c3216
downloadpackages-326080dad9007eda7ddba7ffb3de19b302fe49bb.tar.gz
packages-326080dad9007eda7ddba7ffb3de19b302fe49bb.tar.bz2
packages-326080dad9007eda7ddba7ffb3de19b302fe49bb.zip
Add to AUR
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD33
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..776631c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
1pkgbase = tlsx
2 pkgdesc = Fast and configurable TLS grabber focused on TLS based data collection
3 pkgver = 1.1.7
4 pkgrel = 1
5 url = https://github.com/projectdiscovery/tlsx
6 arch = x86_64
7 license = MIT
8 makedepends = go
9 source = tlsx-1.1.7.tar.gz::https://github.com/projectdiscovery/tlsx/archive/refs/tags/v1.1.7.tar.gz
10 sha256sums = 2fdf4a46bed59595566a532f3bc30c758a892668a0409e7f5b54320d6235c68d
11
12pkgname = tlsx
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..9f2d45b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=tlsx
4pkgver=1.1.7
5pkgrel=1
6pkgdesc=" Fast and configurable TLS grabber focused on TLS based data collection"
7arch=('x86_64')
8url="https://github.com/projectdiscovery/tlsx"
9license=('MIT')
10makedepends=('go')
11source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
12sha256sums=('2fdf4a46bed59595566a532f3bc30c758a892668a0409e7f5b54320d6235c68d')
13
14prepare() {
15 cd "${pkgname}-${pkgver}"
16 mkdir -p build/
17}
18
19build() {
20 cd "${pkgname}-${pkgver}"
21 export CGO_CPPFLAGS="${CPPFLAGS}"
22 export CGO_CFLAGS="${CFLAGS}"
23 export CGO_CXXFLAGS="${CXXFLAGS}"
24 export CGO_LDFLAGS="${LDFLAGS}"
25 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
26 go build -o build ./cmd/...
27}
28
29package() {
30 cd "${pkgname}-${pkgver}"
31 install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
32 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
33}