diff options
author | Yigit Sever | 2021-11-03 20:18:51 +0300 |
---|---|---|
committer | Yigit Sever | 2021-11-03 20:18:51 +0300 |
commit | 18c0df690607f56c2ccb7dcf23a03e6df8a15f9e (patch) | |
tree | 00e462754a0b7dd2d5eaaec2c423747b12d9deee | |
parent | 22b31065aef12ec6b836857f563d7b6a4d33aeeb (diff) | |
download | packages-18c0df690607f56c2ccb7dcf23a03e6df8a15f9e.tar.gz packages-18c0df690607f56c2ccb7dcf23a03e6df8a15f9e.tar.bz2 packages-18c0df690607f56c2ccb7dcf23a03e6df8a15f9e.zip |
Add new conflict, install license
-rw-r--r-- | .SRCINFO | 3 | ||||
-rw-r--r-- | PKGBUILD | 14 |
2 files changed, 10 insertions, 7 deletions
@@ -1,12 +1,13 @@ | |||
1 | pkgbase = ouch | 1 | pkgbase = ouch |
2 | pkgdesc = Painless compression and decompression in the terminal | 2 | pkgdesc = Painless compression and decompression in the terminal |
3 | pkgver = 0.3.1 | 3 | pkgver = 0.3.1 |
4 | pkgrel = 2 | 4 | pkgrel = 3 |
5 | url = https://github.com/ouch-org/ouch | 5 | url = https://github.com/ouch-org/ouch |
6 | arch = x86_64 | 6 | arch = x86_64 |
7 | license = MIT | 7 | license = MIT |
8 | makedepends = cargo | 8 | makedepends = cargo |
9 | conflicts = ouch-git | 9 | conflicts = ouch-git |
10 | conflicts = ouch-bin | ||
10 | source = ouch-0.3.1.tar.gz::https://github.com/ouch-org/ouch/archive/0.3.1.tar.gz | 11 | source = ouch-0.3.1.tar.gz::https://github.com/ouch-org/ouch/archive/0.3.1.tar.gz |
11 | sha256sums = 269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d | 12 | sha256sums = 269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d |
12 | 13 | ||
@@ -2,37 +2,39 @@ | |||
2 | 2 | ||
3 | pkgname=ouch | 3 | pkgname=ouch |
4 | pkgver=0.3.1 | 4 | pkgver=0.3.1 |
5 | pkgrel=2 | 5 | pkgrel=3 |
6 | pkgdesc="Painless compression and decompression in the terminal" | 6 | pkgdesc="Painless compression and decompression in the terminal" |
7 | arch=('x86_64') | 7 | arch=('x86_64') |
8 | url="https://github.com/ouch-org/ouch" | 8 | url="https://github.com/ouch-org/ouch" |
9 | license=('MIT') | 9 | license=('MIT') |
10 | makedepends=('cargo') | 10 | makedepends=('cargo') |
11 | conflicts=(${pkgname}-git) | 11 | conflicts=(${pkgname}-git ${pkgname}-bin) |
12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | 12 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") |
13 | sha256sums=('269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d') | 13 | sha256sums=('269abaf5ac2f80da3796dbf5e73419c1b64104d1295f3ff57965141f079e6f6d') |
14 | 14 | ||
15 | prepare() { | 15 | prepare() { |
16 | cd "$pkgname-$pkgver" | 16 | cd "$srcdir/$pkgname-$pkgver" |
17 | cargo fetch --locked --target "$CARCH-unknown-linux-gnu" | 17 | cargo fetch --locked --target "$CARCH-unknown-linux-gnu" |
18 | } | 18 | } |
19 | 19 | ||
20 | build() { | 20 | build() { |
21 | cd "$pkgname-$pkgver" | 21 | cd "$srcdir/$pkgname-$pkgver" |
22 | export RUSTUP_TOOLCHAIN=stable | 22 | export RUSTUP_TOOLCHAIN=stable |
23 | export CARGO_TARGET_DIR=target | 23 | export CARGO_TARGET_DIR=target |
24 | GEN_COMPLETIONS=1 cargo build --frozen --release --all-features | 24 | GEN_COMPLETIONS=1 cargo build --frozen --release --all-features |
25 | } | 25 | } |
26 | 26 | ||
27 | check() { | 27 | check() { |
28 | cd "$pkgname-$pkgver" | 28 | cd "$srcdir/$pkgname-$pkgver" |
29 | export RUSTUP_TOOLCHAIN=stable | 29 | export RUSTUP_TOOLCHAIN=stable |
30 | cargo test --frozen --all-features | 30 | cargo test --frozen --all-features |
31 | } | 31 | } |
32 | 32 | ||
33 | package() { | 33 | package() { |
34 | cd "$pkgname-$pkgver" | 34 | cd "$srcdir/$pkgname-$pkgver" |
35 | |||
35 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname" | 36 | install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname" |
37 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
36 | 38 | ||
37 | cd target/release/build/ouch-*/out/completions | 39 | cd target/release/build/ouch-*/out/completions |
38 | sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch | 40 | sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch |