summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2022-12-19 21:16:59 +0300
committerYigit Sever2022-12-19 21:16:59 +0300
commit046962cfef122e4dee11fcf46f7c5102ea2eafca (patch)
tree4e30721a1fd751e0de7f824a978458a169dd9398
parenta77f84f7cc785006dbd6d5cf68277f194dbac3b4 (diff)
downloadpackages-046962cfef122e4dee11fcf46f7c5102ea2eafca.tar.gz
packages-046962cfef122e4dee11fcf46f7c5102ea2eafca.tar.bz2
packages-046962cfef122e4dee11fcf46f7c5102ea2eafca.zip
gourmand: Use sqlalchemy1.3
-rw-r--r--gourmand/.SRCINFO4
-rw-r--r--gourmand/PKGBUILD6
2 files changed, 4 insertions, 6 deletions
diff --git a/gourmand/.SRCINFO b/gourmand/.SRCINFO
index 37b6460..de3e92c 100644
--- a/gourmand/.SRCINFO
+++ b/gourmand/.SRCINFO
@@ -1,7 +1,7 @@
1pkgbase = gourmand 1pkgbase = gourmand
2 pkgdesc = A recipe manager for desktop that can import recipes 2 pkgdesc = A recipe manager for desktop that can import recipes
3 pkgver = 1.0.0 3 pkgver = 1.0.0
4 pkgrel = 3 4 pkgrel = 4
5 url = https://github.com/GourmandRecipeManager/gourmand 5 url = https://github.com/GourmandRecipeManager/gourmand
6 arch = any 6 arch = any
7 license = GPL 7 license = GPL
@@ -12,7 +12,7 @@ pkgbase = gourmand
12 depends = python-pyenchant 12 depends = python-pyenchant
13 depends = gst-python 13 depends = gst-python
14 depends = python-pillow 14 depends = python-pillow
15 depends = python-sqlalchemy 15 depends = python-sqlalchemy1.3
16 depends = python-lxml 16 depends = python-lxml
17 depends = python-cairo 17 depends = python-cairo
18 depends = python-requests 18 depends = python-requests
diff --git a/gourmand/PKGBUILD b/gourmand/PKGBUILD
index 92e52c9..610fd62 100644
--- a/gourmand/PKGBUILD
+++ b/gourmand/PKGBUILD
@@ -2,14 +2,13 @@
2 2
3pkgname='gourmand' 3pkgname='gourmand'
4pkgver=1.0.0 4pkgver=1.0.0
5pkgrel=3 5pkgrel=4
6pkgdesc="A recipe manager for desktop that can import recipes" 6pkgdesc="A recipe manager for desktop that can import recipes"
7arch=('any') 7arch=('any')
8url="https://github.com/GourmandRecipeManager/gourmand" 8url="https://github.com/GourmandRecipeManager/gourmand"
9license=('GPL') 9license=('GPL')
10depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests') 10depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy1.3' 'python-lxml' 'python-cairo' 'python-requests')
11makedepends=('python-pip' 'gendesk') 11makedepends=('python-pip' 'gendesk')
12checkdepends=()
13optdepends=( 12optdepends=(
14 'python-beautifulsoup4: Webpage import plugin' 13 'python-beautifulsoup4: Webpage import plugin'
15 'python-scrape-schema-recipe: Webpage import plugin' 14 'python-scrape-schema-recipe: Webpage import plugin'
@@ -31,7 +30,6 @@ prepare() {
31} 30}
32 31
33package() { 32package() {
34 # https://wiki.archlinux.org/title/Python_package_guidelines#pip
35 PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl 33 PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
36 install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" 34 install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
37} 35}