aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2023-01-23 23:46:04 +0300
committerYigit Sever2023-01-23 23:46:04 +0300
commit0453d5aa7199311c0dbb07b7eaea540f54b46734 (patch)
tree40be9672dc53c17076a8eeb5a824c5c139ba4381
parentc2e77baada5e3f1dfd329a669d2bcf21795f36fd (diff)
parent173829b6660cc8956e522dcbf93e47ecc0c38dc6 (diff)
downloadpackages-0453d5aa7199311c0dbb07b7eaea540f54b46734.tar.gz
packages-0453d5aa7199311c0dbb07b7eaea540f54b46734.tar.bz2
packages-0453d5aa7199311c0dbb07b7eaea540f54b46734.zip
Add 'htpdate/' from commit '173829b6660cc8956e522dcbf93e47ecc0c38dc6'
git-subtree-dir: htpdate git-subtree-mainline: c2e77baada5e3f1dfd329a669d2bcf21795f36fd git-subtree-split: 173829b6660cc8956e522dcbf93e47ecc0c38dc6
-rw-r--r--htpdate/.SRCINFO15
-rw-r--r--htpdate/.gitignore4
-rw-r--r--htpdate/PKGBUILD29
-rw-r--r--htpdate/htpdate.service11
4 files changed, 59 insertions, 0 deletions
diff --git a/htpdate/.SRCINFO b/htpdate/.SRCINFO
new file mode 100644
index 0000000..be3270b
--- /dev/null
+++ b/htpdate/.SRCINFO
@@ -0,0 +1,15 @@
1pkgbase = htpdate
2 pkgdesc = HTTP Time protocol
3 pkgver = 1.3.6
4 pkgrel = 1
5 url = https://github.com/twekkel/htpdate
6 arch = i686
7 arch = x86_64
8 license = GPL2
9 depends = glibc
10 source = htpdate-1.3.6.tar.gz::https://github.com/twekkel/htpdate/archive/v1.3.6.tar.gz
11 source = htpdate.service
12 sha256sums = 3cdc558ec8e53ef374a42490b2f28c0b23981fa8754a6d7182044707828ad1e9
13 sha256sums = 2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b
14
15pkgname = htpdate
diff --git a/htpdate/.gitignore b/htpdate/.gitignore
new file mode 100644
index 0000000..aece887
--- /dev/null
+++ b/htpdate/.gitignore
@@ -0,0 +1,4 @@
1/update
2/htpdate-*.tar.*
3/pkg/
4/src/
diff --git a/htpdate/PKGBUILD b/htpdate/PKGBUILD
new file mode 100644
index 0000000..bc2db96
--- /dev/null
+++ b/htpdate/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com>
3# Contributor: Jonathan Ryan <jryan at curious-computing dot com>
4# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
5
6pkgname=htpdate
7pkgver=1.3.6
8pkgrel=1
9pkgdesc="HTTP Time protocol"
10arch=('i686' 'x86_64')
11url="https://github.com/twekkel/htpdate"
12license=(GPL2)
13depends=('glibc')
14source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
15 "htpdate.service")
16sha256sums=('3cdc558ec8e53ef374a42490b2f28c0b23981fa8754a6d7182044707828ad1e9'
17 '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b')
18
19build() {
20 cd ${pkgname}-${pkgver}
21 make
22}
23
24package() {
25 install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
26 cd ${pkgname}-${pkgver}
27 install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate
28 install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
29}
diff --git a/htpdate/htpdate.service b/htpdate/htpdate.service
new file mode 100644
index 0000000..509b072
--- /dev/null
+++ b/htpdate/htpdate.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Htpdate daemon
3
4[Service]
5Type=forking
6PIDFile=/run/htpdate.pid
7ExecStart=/usr/bin/htpdate -D -a -s -i /run/htpdate.pid www.linux.org www.freebsd.org ntp.neu.edu.cn www.kernel.org
8
9[Install]
10WantedBy=multi-user.target
11