aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2024-02-11 18:21:17 +0300
committerYigit Sever2024-02-11 18:21:17 +0300
commit029d60a29ae7d9288169bf03b70d51bcb101d8a8 (patch)
treed7b3e9c4cdbca33da9a8dc989c779ad1ca875d78
parent7d0ed71ddefc5c42600bfdc8ed857627f4517fe4 (diff)
parent91fbf00d9b09ca4857ac1d4b258b0aaec419a27e (diff)
downloadpackages-029d60a29ae7d9288169bf03b70d51bcb101d8a8.tar.gz
packages-029d60a29ae7d9288169bf03b70d51bcb101d8a8.tar.bz2
packages-029d60a29ae7d9288169bf03b70d51bcb101d8a8.zip
Add 'popcorntime-bin/' from commit '91fbf00d9b09ca4857ac1d4b258b0aaec419a27e'
git-subtree-dir: popcorntime-bin git-subtree-mainline: 7d0ed71ddefc5c42600bfdc8ed857627f4517fe4 git-subtree-split: 91fbf00d9b09ca4857ac1d4b258b0aaec419a27e
-rw-r--r--popcorntime-bin/.SRCINFO23
-rw-r--r--popcorntime-bin/.gitignore4
-rw-r--r--popcorntime-bin/PKGBUILD61
-rw-r--r--popcorntime-bin/popcorntime.desktop9
4 files changed, 97 insertions, 0 deletions
diff --git a/popcorntime-bin/.SRCINFO b/popcorntime-bin/.SRCINFO
new file mode 100644
index 0000000..37710d8
--- /dev/null
+++ b/popcorntime-bin/.SRCINFO
@@ -0,0 +1,23 @@
1pkgbase = popcorntime-bin
2 pkgdesc = Stream free movies and TV shows from torrents
3 pkgver = 0.4.9
4 pkgrel = 1
5 url = https://github.com/popcorn-official/popcorn-desktop
6 arch = x86_64
7 license = GPL3
8 makedepends = unzip
9 depends = nss
10 depends = ttf-font
11 depends = libxss
12 depends = gtk3
13 provides = popcorntime
14 provides = popcorntime-ce
15 conflicts = popcorntime
16 conflicts = popcorntime-ce
17 options = !strip
18 source = https://github.com/popcorn-official/popcorn-desktop/releases/download/v0.4.9/Popcorn-Time-0.4.9-linux64.zip
19 source = popcorntime.desktop
20 sha256sums = 71b28be5b8307990ffc9f8bff0a4b42fb45a85af0f4c7a889b8a923c589d8d47
21 sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334
22
23pkgname = popcorntime-bin
diff --git a/popcorntime-bin/.gitignore b/popcorntime-bin/.gitignore
new file mode 100644
index 0000000..a954168
--- /dev/null
+++ b/popcorntime-bin/.gitignore
@@ -0,0 +1,4 @@
1*.log
2Popcorn-Time-*-linux64.zip
3popcorntime-bin-*.pkg.tar.xz
4popcorntime-bin-*.pkg.tar.zst
diff --git a/popcorntime-bin/PKGBUILD b/popcorntime-bin/PKGBUILD
new file mode 100644
index 0000000..c59e8cc
--- /dev/null
+++ b/popcorntime-bin/PKGBUILD
@@ -0,0 +1,61 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor : Barfin
3# Contributor: Kostis Karantias <kkarantias [at] gmail [dot] com>
4# Contributor: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com>
5# Contributor: Bastien Traverse <firstname at lastname dot email>
6# Contributor: Ricardo Funke <ricardo [at] gmail [dot] com>
7# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
8# Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com>
9# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
10# Contributor: Ricardo Band <me [at] xengi [dot] de>
11# Contributor: Axilleas Pipinellis (aka axil42) <axilleas [at] archlinux [dot] info>
12# Contributor: UshakovVasilii <UshakovVasilii [at] yahoo [dot] com>
13# Contributor: Giulio Fidente <gfidente [at] gmail [dot] com>
14# Contributor: xantares <xantares09 [at] hotmail [dot] com>
15# Contributor: petterk <stifler3k [at] hotmail [dot] com>
16# Contributor: Stephan Springer <buzo+arch (at) Lini (dot) de>
17
18pkgname=popcorntime-bin
19_pkgname=popcorntime
20pkgver=0.4.9
21pkgrel=1
22pkgdesc="Stream free movies and TV shows from torrents"
23arch=('x86_64')
24url="https://github.com/popcorn-official/popcorn-desktop"
25license=('GPL3')
26depends=('nss' 'ttf-font' 'libxss' 'gtk3')
27makedepends=('unzip')
28provides=('popcorntime' 'popcorntime-ce')
29conflicts=('popcorntime' 'popcorntime-ce')
30options=('!strip')
31_zipfile="Popcorn-Time-${pkgver}-linux64.zip"
32source=("https://github.com/popcorn-official/popcorn-desktop/releases/download/v${pkgver}/$_zipfile"
33 "${_pkgname}.desktop" )
34sha256sums=('fcf9c4d6ccd4fccaf7668707b16dcdd78d043b2d4f2a049f0edaf7afd8bb34f1'
35 '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
36
37package() {
38 install -dm755 "${pkgdir}/usr/share/${_pkgname}"
39 install -dm755 "${pkgdir}/usr/bin"
40
41 # Link to program
42 ln -s "../share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}"
43
44 # Desktop file
45 install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
46
47 # Icon
48 install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
49
50 # Remove makepkg-created symlinks before copying content
51 rm "$_zipfile" "${_pkgname}.desktop"
52
53 # Copy complete content of source archive to /usr/share/${_pkgname}
54 cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}"
55
56 # Fix permissions
57 find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \;
58 find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \;
59}
60sha256sums=('71b28be5b8307990ffc9f8bff0a4b42fb45a85af0f4c7a889b8a923c589d8d47'
61 '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
diff --git a/popcorntime-bin/popcorntime.desktop b/popcorntime-bin/popcorntime.desktop
new file mode 100644
index 0000000..3b39b63
--- /dev/null
+++ b/popcorntime-bin/popcorntime.desktop
@@ -0,0 +1,9 @@
1[Desktop Entry]
2Name=Popcorn Time
3Comment=Watch Movies and TV Shows instantly
4Exec=popcorntime %U
5Icon=popcorntime
6MimeType=application/x-bittorrent;x-scheme-handler/magnet;
7StartupNotify=false
8Categories=AudioVideo;Video;Network;Player;P2P;
9Type=Application