aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorYigit Sever2021-04-14 03:27:27 +0300
committerYigit Sever2021-04-14 19:11:49 +0300
commitedfab6ae2f97a7288ff456265050c01ff397ea8c (patch)
treee98ce8b12c1ef4d61c70944f47d87d74297a8ed3 /Cargo.toml
parenta5d5ab88d3f73d0b6f5fa847df6dace90810313d (diff)
downloadgradecoin-edfab6ae2f97a7288ff456265050c01ff397ea8c.tar.gz
gradecoin-edfab6ae2f97a7288ff456265050c01ff397ea8c.tar.bz2
gradecoin-edfab6ae2f97a7288ff456265050c01ff397ea8c.zip
[WIP] Initial implementation of user auth
There is a dance involved and everything Write down specs for RSA and AES, padding scheme, ugh.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6701daf..3b6e71e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,6 +20,9 @@ blake2 = "0.9.1"
20hex-literal = "0.3.1" 20hex-literal = "0.3.1"
21jsonwebtoken = "7.2.0" 21jsonwebtoken = "7.2.0"
22md-5 = "0.9.1" 22md-5 = "0.9.1"
23rsa = "0.4.0"
24base64 = "0.13.0"
25sha2 = "0.9.3"
23 26
24[dev-dependencies] 27[dev-dependencies]
25serde_test = "1.0.117" 28serde_test = "1.0.117"