From f1ae3ccc4fcf4728212680f4488e6cf90f9c7fcb Mon Sep 17 00:00:00 2001
From: Yigit Sever
Date: Thu, 15 Dec 2022 22:46:20 +0300
Subject: heisenbridge: Update to 1.14.0-1

upstream release
---
 PKGBUILD | 20 +++++++++++---------
 1 file changed, 11 insertions(+), 9 deletions(-)

(limited to 'PKGBUILD')

diff --git a/PKGBUILD b/PKGBUILD
index c1bd9cf..2183544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: Bjoern Franke <bjo+aur@schafweide.org>
+# Maintainer: Yigit Sever <yigit at yigitsever dot com>
+# Contributor: Bjoern Franke <bjo+aur@schafweide.org>
+
 pkgname=heisenbridge
-pkgver=1.13.1
+pkgver=1.14.0
 pkgrel=1
 pkgdesc="a bouncer-style Matrix IRC bridge"
 url="https://github.com/hifi/heisenbridge"
 depends=('python' 'python-irc' 'python-ruamel-yaml' 'python-aiohttp-socks'
-	'python-mautrix>=0.14.0' 'python-mautrix<0.17')
+	'python-mautrix')
 makedepends=('python-setuptools' 'python-pytest-runner')
 license=('MIT')
 arch=('any')
 source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz" "${pkgname}.service" "${pkgname}.sysusers" "${pkgname}.tmpfiles")
-sha256sums=('92e561db62eba63a31899d6f697eb292ca2273beaf195c13132dab5c4101873e'
+sha256sums=('ba31d167982f022740abf1f785d32d959d9b35f64205d2f1e64d1d54e06f9b55'
             '67487b221bff329952f5c95186c4ea794c7e7a3e25e6d213075fd306c68cfa95'
             'b3bc4328ead7afd186d5a191fabc347543c0fad17dc01047a4cf0532d999f255'
             '24bd23e4427aaf635a91b170c07abe8a6b1c62cbad47e50a161c12807641d351')
@@ -18,11 +20,11 @@ backup=("etc/${pkgname}/registration.yaml")
 install="${pkgname}.install"
 _dirname="${pkgname}-${pkgver}"
 
-
 prepare() {
 	cd "${srcdir}/${_dirname}"
-	# create an empty registration file so that permissions get written properly from the get go
-	# this way secret keys are never world readable
+	# create an empty registration file so that permissions get written
+	# properly from the get go this way secret keys are never world
+	# readable
 	touch registration.yaml
 }
 
@@ -38,8 +40,8 @@ package() {
 
 	python setup.py install --optimize=1 --skip-build --root="${pkgdir}/" --prefix="/usr" --install-data="${_shared_dir}"
 
-	# it's a semi-common failure for python packages to install tests in the main dir
-	# which would make them conflict eachother
+	# it's a semi-common failure for python packages to install tests in
+	# the main dir which would make them conflict eachother
 	rm -rf "${pkgdir}$(python -c 'import site; print(site.getsitepackages()[0])')/tests"
 
 	install -Dvm 644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
-- 
cgit v1.2.3-70-g09d2