From 95fd0d6f59ee6552307a92dc9cd68f61b88f6fb5 Mon Sep 17 00:00:00 2001
From: syui
Date: Sun, 10 Jun 2018 14:01:54 +0900
Subject: first

---
 .SRCINFO   | 19 +++++++++++++++++++
 .gitignore |  3 +++
 PKGBUILD   | 34 ++++++++++++++++++++++++++++++++++
 3 files changed, 56 insertions(+)
 create mode 100644 .SRCINFO
 create mode 100644 .gitignore
 create mode 100644 PKGBUILD

diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..66a46eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xq
+	pkgdesc = xml to json convert parser
+	pkgver = 0.1
+	pkgrel = 1
+	url = https://github.com/syui/xq
+	arch = x86_64
+	arch = i686
+	license = MIT
+	noextract = https://github.com/syui/xq/releases/download/0.1/linux_386_xq
+	noextract = https://github.com/syui/xq/releases/download/0.1/linux_amd64_xq
+	options = !strip
+	options = !emptydirs
+	source = https://github.com/syui/xq/releases/download/0.1/linux_386_xq
+	source = https://github.com/syui/xq/releases/download/0.1/linux_amd64_xq
+	sha1sums = ec49fc225d79473b11790e79d7c1c57b3b829cff
+	sha1sums = 883a2ec0dea0d449b34664367912af289d0b5943
+
+pkgname = xq
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..c0d838f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+linux_amd64_xq
+linux_386_xq
+xq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..3359554
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: syui <syui@users.noreply.github.com>
+pkgname=xq
+pkgver=0.1
+pkgrel=1
+pkgdesc="xml to json convert parser"
+arch=('x86_64' 'i686')
+url="https://github.com/syui/xq"
+options=('!strip' '!emptydirs')
+license=('MIT')
+source=("$url/releases/download/$pkgver/linux_386_$pkgname"
+  "$url/releases/download/$pkgver/linux_amd64_$pkgname")
+noextract=(${source[@]%%::*})
+sha1sums=('ec49fc225d79473b11790e79d7c1c57b3b829cff'
+  '883a2ec0dea0d449b34664367912af289d0b5943')
+
+package() {
+  mkdir -p ${srcdir}/${pkgname}-${pkgver}
+  cd "${srcdir}/${pkgname}-${pkgver}"
+ 
+  if [ "`uname -m`" = "x86_64" ];then
+    mv ../linux_amd64_$pkgname $pkgname 
+    chmod +x $pkgname
+  fi
+
+  if [ "`uname -m`" = "i684" ];then
+    mv ../linux_386_$pkgname $pkgname 
+    chmod +x $pkgname
+  fi
+
+  install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+  #sudo install -Dm755 "$pkgdir/usr/bin/$pkgname" /usr/bin
+}
+
+# vim:set ts=2 sw=2 et:
-- 
cgit v1.2.3-70-g09d2