diff options
Diffstat (limited to 'wapiti/PKGBUILD')
-rw-r--r-- | wapiti/PKGBUILD | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/wapiti/PKGBUILD b/wapiti/PKGBUILD new file mode 100644 index 0000000..d645313 --- /dev/null +++ b/wapiti/PKGBUILD | |||
@@ -0,0 +1,41 @@ | |||
1 | # Maintainer : Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/) | ||
3 | # Contributor : mickael9 <mickael9 at gmail dot com> | ||
4 | |||
5 | pkgname=wapiti | ||
6 | pkgver=3.1.3 | ||
7 | _name="$pkgname${pkgver:0:1}" | ||
8 | pkgrel=1 | ||
9 | pkgdesc='Comprehensive web app vulnerability scanner written in Python' | ||
10 | arch=('any') | ||
11 | url="https://$pkgname-scanner.github.io" | ||
12 | license=('GPL') | ||
13 | makedepends=('python-setuptools') | ||
14 | depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp' | ||
15 | 'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx' | ||
16 | 'python-aiocache' 'python-aiosqlite' 'python-sqlalchemy' 'python-loguru' 'python-cryptography') | ||
17 | optdepends=('python-requests-kerberos: Kerberos authentication' | ||
18 | 'python-requests-ntlm: NTLM authentication') | ||
19 | options=('zipman') | ||
20 | changelog=ChangeLog | ||
21 | source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz") | ||
22 | sha256sums=('83ffef39199f92f530f7de7b47dbfb93ab2c9c97d3bbee93473084cba5796c61') | ||
23 | |||
24 | prepare() { | ||
25 | rm -rf "$_name-$pkgver/tests" | ||
26 | } | ||
27 | |||
28 | build() { | ||
29 | cd "$_name-$pkgver" | ||
30 | sed -i '/mitmproxy==8.0.0/s/==8.0.0/>=8.0.0/' setup.py | ||
31 | sed -i '/dnspython==2.1.0/s/==2.1.0/>=2.1.0/' setup.py | ||
32 | sed -i '/cryptography==36.0.2/s/==36.0.2/>=36.0.2/' setup.py | ||
33 | sed -i '/browser-cookie3==0.11.4/s/==0.11.4/>=0.11.4/' setup.py | ||
34 | sed -i '/importlib_metadata==3.7.2/s/==3.7.2/>=3.7.2/' setup.py | ||
35 | python setup.py build | ||
36 | } | ||
37 | |||
38 | package() { | ||
39 | cd "$_name-$pkgver" | ||
40 | PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build | ||
41 | } | ||