diff options
Diffstat (limited to 'unsilence')
-rw-r--r-- | unsilence/.SRCINFO | 15 | ||||
-rw-r--r-- | unsilence/.gitignore | 4 | ||||
-rw-r--r-- | unsilence/PKGBUILD | 28 |
3 files changed, 47 insertions, 0 deletions
diff --git a/unsilence/.SRCINFO b/unsilence/.SRCINFO new file mode 100644 index 0000000..e8f8045 --- /dev/null +++ b/unsilence/.SRCINFO | |||
@@ -0,0 +1,15 @@ | |||
1 | pkgbase = unsilence | ||
2 | pkgdesc = Console Interface and Library to remove silent parts of a media file | ||
3 | pkgver = 1.0.9 | ||
4 | pkgrel = 2 | ||
5 | url = https://github.com/lagmoellertim/unsilence | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | makedepends = python-setuptools | ||
9 | depends = ffmpeg | ||
10 | depends = python | ||
11 | depends = python-rich | ||
12 | source = unsilence-1.0.9.tar.gz::https://github.com/lagmoellertim/unsilence/archive/1.0.9.tar.gz | ||
13 | sha256sums = 5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b | ||
14 | |||
15 | pkgname = unsilence | ||
diff --git a/unsilence/.gitignore b/unsilence/.gitignore new file mode 100644 index 0000000..05c6d4d --- /dev/null +++ b/unsilence/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | * | ||
2 | !.gitignore | ||
3 | !.SRCINFO | ||
4 | !PKGBUILD | ||
diff --git a/unsilence/PKGBUILD b/unsilence/PKGBUILD new file mode 100644 index 0000000..973c29d --- /dev/null +++ b/unsilence/PKGBUILD | |||
@@ -0,0 +1,28 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> | ||
3 | |||
4 | pkgname=unsilence | ||
5 | pkgver=1.0.9 | ||
6 | pkgrel=2 | ||
7 | pkgdesc='Console Interface and Library to remove silent parts of a media file' | ||
8 | arch=('any') | ||
9 | url='https://github.com/lagmoellertim/unsilence' | ||
10 | license=('MIT') | ||
11 | depends=('ffmpeg' 'python' 'python-rich') | ||
12 | makedepends=('python-setuptools') | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
14 | sha256sums=('5ce2efff1cbbdb42b66bf3eb28f326a51bed2a03ddf57de02cd6a634ca15cc5b') | ||
15 | |||
16 | build() { | ||
17 | cd "${pkgname}-${pkgver}" | ||
18 | sed -i 's/rich~=10.10.0/rich>=10.10.0/' requirements.txt | ||
19 | python setup.py build | ||
20 | } | ||
21 | |||
22 | package() { | ||
23 | cd "${pkgname}-${pkgver}" | ||
24 | python setup.py install --root="${pkgdir}" --optimize=1 --skip-build | ||
25 | install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md' | ||
26 | install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE' | ||
27 | rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples' | ||
28 | } | ||