diff options
Diffstat (limited to 'tlsx/PKGBUILD')
-rw-r--r-- | tlsx/PKGBUILD | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/tlsx/PKGBUILD b/tlsx/PKGBUILD new file mode 100644 index 0000000..535ce15 --- /dev/null +++ b/tlsx/PKGBUILD | |||
@@ -0,0 +1,33 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=tlsx | ||
4 | pkgver=1.1.8 | ||
5 | pkgrel=1 | ||
6 | pkgdesc=" Fast and configurable TLS grabber focused on TLS based data collection" | ||
7 | arch=('x86_64') | ||
8 | url="https://github.com/projectdiscovery/tlsx" | ||
9 | license=('MIT') | ||
10 | makedepends=('go') | ||
11 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz") | ||
12 | sha256sums=('272330eb814dc79d367b18c9aa5033a507f9214616d97ac4c1b2f75054767504') | ||
13 | |||
14 | prepare() { | ||
15 | cd "${pkgname}-${pkgver}" | ||
16 | mkdir -p build/ | ||
17 | } | ||
18 | |||
19 | build() { | ||
20 | cd "${pkgname}-${pkgver}" | ||
21 | export CGO_CPPFLAGS="${CPPFLAGS}" | ||
22 | export CGO_CFLAGS="${CFLAGS}" | ||
23 | export CGO_CXXFLAGS="${CXXFLAGS}" | ||
24 | export CGO_LDFLAGS="${LDFLAGS}" | ||
25 | export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" | ||
26 | go build -o build ./cmd/... | ||
27 | } | ||
28 | |||
29 | package() { | ||
30 | cd "${pkgname}-${pkgver}" | ||
31 | install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname | ||
32 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
33 | } | ||