diff options
Diffstat (limited to 'serviio/PKGBUILD')
-rw-r--r-- | serviio/PKGBUILD | 65 |
1 files changed, 65 insertions, 0 deletions
diff --git a/serviio/PKGBUILD b/serviio/PKGBUILD new file mode 100644 index 0000000..36f78f6 --- /dev/null +++ b/serviio/PKGBUILD | |||
@@ -0,0 +1,65 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: lesebas | ||
3 | # Contributor: Seb Deligny | ||
4 | pkgname=serviio | ||
5 | pkgver=2.2 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Free DLNA media server" | ||
8 | arch=('any') | ||
9 | url="http://www.serviio.org/" | ||
10 | license=('custom') | ||
11 | depends=('java-runtime-headless>=8' 'ffmpeg') | ||
12 | source=(http://download.serviio.org/releases/serviio-${pkgver}-linux.tar.gz | ||
13 | $pkgname.sh | ||
14 | $pkgname.service | ||
15 | $pkgname.desktop | ||
16 | $pkgname.png) | ||
17 | md5sums=('ac450526d38a496d3aaa700edae9c683' | ||
18 | '227a75de2dea1db93c1fba3d004e01ad' | ||
19 | 'e958d9812448f97fe325dfffe8b44620' | ||
20 | 'fbfcac4ad5dffd909e51ea1a7a6335aa' | ||
21 | 'd41e3e757e412dfcd3036d9e19b81450') | ||
22 | |||
23 | package() { | ||
24 | cd "$pkgname-$pkgver" | ||
25 | |||
26 | # define variable for Serviio home directory | ||
27 | SERVIIO_HOME=$pkgdir/usr/share/java/$pkgname | ||
28 | |||
29 | # create the folders needed in the main directory | ||
30 | install -dm755 ${SERVIIO_HOME}/{config,lib,library,plugins} | ||
31 | |||
32 | # place the serviio scripts in the /usr/bin folder | ||
33 | install -Dm755 ${srcdir}/$pkgname.sh $pkgdir/usr/bin/$pkgname | ||
34 | install -Dm755 bin/$pkgname-console.sh $pkgdir/usr/bin/$pkgname-console | ||
35 | |||
36 | # copy xml config files to the config folder | ||
37 | install -m644 config/*.xml ${SERVIIO_HOME}/config | ||
38 | |||
39 | # copy all jar files to the lib folder | ||
40 | install -m644 lib/*.jar ${SERVIIO_HOME}/lib | ||
41 | |||
42 | # copy derby.properties to library folder | ||
43 | install -m644 library/derby.properties ${SERVIIO_HOME}/library | ||
44 | |||
45 | # copy plugins-readme.txt to plugins folder | ||
46 | install -m644 plugins/plugins-readme.txt ${SERVIIO_HOME}/plugins | ||
47 | |||
48 | # create the log folder in /var/log | ||
49 | install -dm755 $pkgdir/var/log/$pkgname | ||
50 | |||
51 | # create a symlink that puts all log files in /var/log | ||
52 | ln -s /var/log/$pkgname ${SERVIIO_HOME}/log | ||
53 | |||
54 | # supply the license file | ||
55 | install -Dm644 LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE | ||
56 | |||
57 | # install systemd-service | ||
58 | install -Dm644 "${srcdir}/$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service" | ||
59 | |||
60 | #install the .desktop file | ||
61 | install -Dm644 "${srcdir}/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" | ||
62 | |||
63 | #install the icon file | ||
64 | install -Dm644 "${srcdir}/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png" | ||
65 | } | ||