aboutsummaryrefslogtreecommitdiffstats
path: root/reco/PKGBUILD
diff options
context:
space:
mode:
diffstat (limited to 'reco/PKGBUILD')
-rw-r--r--reco/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/reco/PKGBUILD b/reco/PKGBUILD
new file mode 100644
index 0000000..e9a9ba4
--- /dev/null
+++ b/reco/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname='reco'
5pkgver=4.0.0
6pkgrel=1
7pkgdesc='An audio recording app designed for elementary OS'
8arch=('x86_64')
9url='https://github.com/ryonakano/reco'
10license=('GPL3')
11depends=('granite7' 'gstreamer' 'libpulse')
12makedepends=('meson' 'vala' 'libhandy')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
14sha256sums=('c872e1542d15ba83ac0faa486813686b5f2eb47413b8dd48d477f0ffeec6f0fd')
15
16build() {
17 arch-meson "${pkgname}-${pkgver}" build
18 meson compile -C build
19}
20
21package() {
22 DESTDIR="${pkgdir}" meson install -C build
23 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
24}