summaryrefslogtreecommitdiffstats
path: root/reco/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'reco/PKGBUILD')
-rw-r--r--reco/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/reco/PKGBUILD b/reco/PKGBUILD
new file mode 100644
index 0000000..62d5fd0
--- /dev/null
+++ b/reco/PKGBUILD
@@ -0,0 +1,25 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4pkgname='reco'
5pkgver=5.0.1
6pkgrel=1
7pkgdesc='An audio recording app designed for elementary OS'
8arch=('x86_64')
9url='https://github.com/ryonakano/reco'
10license=('GPL3')
11depends=('granite7' 'gstreamer' 'libpulse' 'ryokucha' 'live-chart')
12makedepends=('meson' 'vala' 'libhandy')
13source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
14sha256sums=('7b8639146d0740798bd844d0b9f005c03acd37f8f87e63f09b8f71270084c664')
15
16build() {
17 arch-meson "${pkgname}-${pkgver}" build -Duse_submodule=false
18 meson compile -C build
19}
20
21package() {
22 DESTDIR="${pkgdir}" meson install -C build
23 ln -s /usr/bin/com.github.ryonakano.reco "${pkgdir}/usr/bin/reco"
24 install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
25}