summaryrefslogtreecommitdiffstats
path: root/quich-git
diff options
context:
space:
mode:
Diffstat (limited to 'quich-git')
-rw-r--r--quich-git/.SRCINFO14
-rw-r--r--quich-git/.gitignore4
-rw-r--r--quich-git/PKGBUILD33
3 files changed, 51 insertions, 0 deletions
diff --git a/quich-git/.SRCINFO b/quich-git/.SRCINFO
new file mode 100644
index 0000000..6b87de9
--- /dev/null
+++ b/quich-git/.SRCINFO
@@ -0,0 +1,14 @@
1pkgbase = quich-git
2 pkgdesc = calculator for terminal with numerous features
3 pkgver = 4.0.0.r3.ged2d2b7
4 pkgrel = 1
5 url = https://github.com/Usbac/quich
6 arch = x86_64
7 license = MIT
8 makedepends = git
9 provides = quich
10 conflicts = quich
11 source = git+https://github.com/Usbac/quich.git
12 sha256sums = SKIP
13
14pkgname = quich-git
diff --git a/quich-git/.gitignore b/quich-git/.gitignore
new file mode 100644
index 0000000..05c6d4d
--- /dev/null
+++ b/quich-git/.gitignore
@@ -0,0 +1,4 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
diff --git a/quich-git/PKGBUILD b/quich-git/PKGBUILD
new file mode 100644
index 0000000..c0ca232
--- /dev/null
+++ b/quich-git/PKGBUILD
@@ -0,0 +1,33 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3# Contributor: vscncls <lucaslou4@protonmail.com>
4
5_pkgname='quich'
6pkgname="${_pkgname}-git"
7pkgver=4.0.0.r3.ged2d2b7
8pkgrel=1
9pkgdesc='calculator for terminal with numerous features'
10arch=('x86_64')
11url='https://github.com/Usbac/quich'
12license=('MIT')
13makedepends=('git')
14provides=("${_pkgname}")
15conflicts=("${_pkgname}")
16source=("git+${url}.git")
17sha256sums=('SKIP')
18
19pkgver() {
20 git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
21}
22
23build() {
24 make -C "${_pkgname}" LDFLAGS="${LDFLAGS}"
25}
26
27package() {
28 cd "${_pkgname}"
29 install -D -m755 "${_pkgname}" -t "${pkgdir}/usr/bin"
30 install -D -m644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
31 install -D -m644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${_pkgname}"
32 install -D -m644 'quich.1' -t "${pkgdir}/usr/share/man/man1"
33}