summaryrefslogtreecommitdiffstats
path: root/python-types-requests
diff options
context:
space:
mode:
Diffstat (limited to 'python-types-requests')
-rw-r--r--python-types-requests/.SRCINFO13
-rw-r--r--python-types-requests/PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/python-types-requests/.SRCINFO b/python-types-requests/.SRCINFO
new file mode 100644
index 0000000..6884b34
--- /dev/null
+++ b/python-types-requests/.SRCINFO
@@ -0,0 +1,13 @@
1pkgbase = python-types-requests
2 pkgdesc = Typing stubs for requests
3 pkgver = 2.28.2
4 pkgrel = 1
5 url = https://pypi.org/project/types-requests/
6 arch = any
7 license = Apache
8 makedepends = python-setuptools
9 depends = python
10 source = https://files.pythonhosted.org/packages/source/t/types-requests/types-requests-2.28.2.tar.gz
11 sha256sums = 398f88cd9302c796cb63d1021af2a1fb7ae507741a3d508edf8e0746d8c16a04
12
13pkgname = python-types-requests
diff --git a/python-types-requests/PKGBUILD b/python-types-requests/PKGBUILD
new file mode 100644
index 0000000..457d896
--- /dev/null
+++ b/python-types-requests/PKGBUILD
@@ -0,0 +1,24 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=python-types-requests
4_name=${pkgname#python-}
5pkgver=2.28.2
6pkgrel=1
7pkgdesc="Typing stubs for requests"
8arch=('any')
9url="https://pypi.org/project/types-requests/"
10license=('Apache')
11depends=('python')
12makedepends=('python-setuptools')
13source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
14sha256sums=('398f88cd9302c796cb63d1021af2a1fb7ae507741a3d508edf8e0746d8c16a04')
15
16build() {
17 cd "$_name-$pkgver"
18 python setup.py build
19}
20
21package() {
22 cd "$_name-$pkgver"
23 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
24}