summaryrefslogtreecommitdiffstats
path: root/python-scrape-schema-recipe
diff options
context:
space:
mode:
Diffstat (limited to 'python-scrape-schema-recipe')
-rw-r--r--python-scrape-schema-recipe/.SRCINFO18
-rw-r--r--python-scrape-schema-recipe/PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/.SRCINFO b/python-scrape-schema-recipe/.SRCINFO
new file mode 100644
index 0000000..4358145
--- /dev/null
+++ b/python-scrape-schema-recipe/.SRCINFO
@@ -0,0 +1,18 @@
1pkgbase = python-scrape-schema-recipe
2 pkgdesc = Scrapes food recipes from HTML into Python dictionaries
3 pkgver = 0.2.0
4 pkgrel = 2
5 url = https://github.com/micahcochran/scrape-schema-recipe
6 arch = any
7 license = Apache
8 makedepends = python-setuptools
9 depends = python-dataclasses
10 depends = python-extruct
11 depends = python-importlib_resources
12 depends = python-isodate
13 depends = python-requests
14 depends = python-types-requests
15 source = python-scrape-schema-recipe-0.2.0.tar.gz::https://github.com/micahcochran/scrape-schema-recipe/archive/v0.2.0.tar.gz
16 sha256sums = ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf
17
18pkgname = python-scrape-schema-recipe
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD
new file mode 100644
index 0000000..0c8b57f
--- /dev/null
+++ b/python-scrape-schema-recipe/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=python-scrape-schema-recipe
4_pkgname=scrape-schema-recipe
5pkgver=0.2.0
6pkgrel=2
7pkgdesc="Scrapes food recipes from HTML into Python dictionaries"
8arch=('any')
9url="https://github.com/micahcochran/scrape-schema-recipe"
10license=('Apache')
11depends=('python-dataclasses'
12 'python-extruct'
13 'python-importlib_resources'
14 'python-isodate'
15 'python-requests'
16 'python-types-requests')
17makedepends=('python-setuptools')
18source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
19sha256sums=('ecc253c82a9346c66e77005680a3f746a2feca7292bbcab0c4357b2757a0d1bf')
20
21build() {
22 cd "${_pkgname}-${pkgver}"
23 python setup.py build
24}
25
26package() {
27 cd "${_pkgname}-${pkgver}"
28 python setup.py install --root="$pkgdir" --optimize=1
29}