diff options
Diffstat (limited to 'python-scrape-schema-recipe/PKGBUILD')
-rw-r--r-- | python-scrape-schema-recipe/PKGBUILD | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/python-scrape-schema-recipe/PKGBUILD b/python-scrape-schema-recipe/PKGBUILD new file mode 100644 index 0000000..254d2cb --- /dev/null +++ b/python-scrape-schema-recipe/PKGBUILD | |||
@@ -0,0 +1,24 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=python-scrape-schema-recipe | ||
4 | _pkgname=scrape-schema-recipe | ||
5 | pkgver=0.2.2 | ||
6 | pkgrel=2 | ||
7 | pkgdesc="Scrapes food recipes from HTML into Python dictionaries" | ||
8 | arch=("any") | ||
9 | url="https://github.com/micahcochran/scrape-schema-recipe" | ||
10 | license=("Apache-2.0") | ||
11 | depends=(python-extruct python-isodate python-requests) | ||
12 | makedepends=(python-setuptools) | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
14 | sha256sums=('aa4004fedb52019d9d627944b03966412b3dda8a96df06c0715aa0889af07216') | ||
15 | |||
16 | build() { | ||
17 | cd "${_pkgname}-${pkgver}" | ||
18 | python setup.py build | ||
19 | } | ||
20 | |||
21 | package() { | ||
22 | cd "${_pkgname}-${pkgver}" | ||
23 | python setup.py install --root="$pkgdir" --optimize=1 | ||
24 | } | ||