diff options
Diffstat (limited to 'python-jstyleson')
-rw-r--r-- | python-jstyleson/.SRCINFO | 13 | ||||
-rw-r--r-- | python-jstyleson/PKGBUILD | 23 |
2 files changed, 36 insertions, 0 deletions
diff --git a/python-jstyleson/.SRCINFO b/python-jstyleson/.SRCINFO new file mode 100644 index 0000000..8111831 --- /dev/null +++ b/python-jstyleson/.SRCINFO | |||
@@ -0,0 +1,13 @@ | |||
1 | pkgbase = python-jstyleson | ||
2 | pkgdesc = Library to parse JSON with js-style comments. | ||
3 | pkgver = 0.0.2 | ||
4 | pkgrel = 1 | ||
5 | url = https://pypi.org/project/jstyleson/ | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | makedepends = python-setuptools | ||
9 | depends = python | ||
10 | source = https://files.pythonhosted.org/packages/source/j/jstyleson/jstyleson-0.0.2.tar.gz | ||
11 | sha256sums = 680003f3b15a2959e4e6a351f3b858e3c07dd3e073a0d54954e34d8ea5e1308e | ||
12 | |||
13 | pkgname = python-jstyleson | ||
diff --git a/python-jstyleson/PKGBUILD b/python-jstyleson/PKGBUILD new file mode 100644 index 0000000..1281310 --- /dev/null +++ b/python-jstyleson/PKGBUILD | |||
@@ -0,0 +1,23 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | pkgname=python-jstyleson | ||
3 | _name=${pkgname#python-} | ||
4 | pkgver=0.0.2 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Library to parse JSON with js-style comments." | ||
7 | arch=('any') | ||
8 | url="https://pypi.org/project/jstyleson/" | ||
9 | license=('MIT') | ||
10 | depends=('python') | ||
11 | makedepends=('python-setuptools') | ||
12 | source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz") | ||
13 | sha256sums=('680003f3b15a2959e4e6a351f3b858e3c07dd3e073a0d54954e34d8ea5e1308e') | ||
14 | |||
15 | build() { | ||
16 | cd "${_name}-${pkgver}" | ||
17 | python setup.py build | ||
18 | } | ||
19 | |||
20 | package() { | ||
21 | cd "${_name}-${pkgver}" | ||
22 | python setup.py install --root="$pkgdir" --optimize=1 | ||
23 | } | ||