aboutsummaryrefslogtreecommitdiffstats
path: root/python-jstyleson/PKGBUILD
diff options
context:
space:
mode:
diffstat (limited to 'python-jstyleson/PKGBUILD')
-rw-r--r--python-jstyleson/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/python-jstyleson/PKGBUILD b/python-jstyleson/PKGBUILD
new file mode 100644
index 0000000..1281310
--- /dev/null
+++ b/python-jstyleson/PKGBUILD
@@ -0,0 +1,23 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2pkgname=python-jstyleson
3_name=${pkgname#python-}
4pkgver=0.0.2
5pkgrel=1
6pkgdesc="Library to parse JSON with js-style comments."
7arch=('any')
8url="https://pypi.org/project/jstyleson/"
9license=('MIT')
10depends=('python')
11makedepends=('python-setuptools')
12source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
13sha256sums=('680003f3b15a2959e4e6a351f3b858e3c07dd3e073a0d54954e34d8ea5e1308e')
14
15build() {
16 cd "${_name}-${pkgver}"
17 python setup.py build
18}
19
20package() {
21 cd "${_name}-${pkgver}"
22 python setup.py install --root="$pkgdir" --optimize=1
23}