diff options
Diffstat (limited to 'python-extruct')
-rw-r--r-- | python-extruct/.SRCINFO | 21 | ||||
-rw-r--r-- | python-extruct/PKGBUILD | 25 |
2 files changed, 46 insertions, 0 deletions
diff --git a/python-extruct/.SRCINFO b/python-extruct/.SRCINFO new file mode 100644 index 0000000..abaf6e5 --- /dev/null +++ b/python-extruct/.SRCINFO | |||
@@ -0,0 +1,21 @@ | |||
1 | pkgbase = python-extruct | ||
2 | pkgdesc = Extract embedded metadata from HTML markup | ||
3 | pkgver = 0.16.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/scrapinghub/extruct | ||
6 | arch = any | ||
7 | license = custom | ||
8 | makedepends = python-setuptools | ||
9 | depends = python-lxml | ||
10 | depends = python-requests | ||
11 | depends = python-rdflib | ||
12 | depends = python-pyrdfa3 | ||
13 | depends = python-mf2py | ||
14 | depends = python-six | ||
15 | depends = python-w3lib | ||
16 | depends = python-html-text | ||
17 | depends = python-jstyleson | ||
18 | source = python-extruct-0.16.0.tar.gz::https://github.com/scrapinghub/extruct/archive/v0.16.0.tar.gz | ||
19 | sha256sums = 9ad821c0f87ce8096d72753e5cbdfbace72569aef298b0ee9b2a46ecb9bc46f3 | ||
20 | |||
21 | pkgname = python-extruct | ||
diff --git a/python-extruct/PKGBUILD b/python-extruct/PKGBUILD new file mode 100644 index 0000000..a19eb52 --- /dev/null +++ b/python-extruct/PKGBUILD | |||
@@ -0,0 +1,25 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=python-extruct | ||
4 | _pkgname=extruct | ||
5 | pkgver=0.16.0 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Extract embedded metadata from HTML markup" | ||
8 | arch=('any') | ||
9 | url="https://github.com/scrapinghub/extruct" | ||
10 | license=('custom') | ||
11 | depends=('python-lxml' 'python-requests' 'python-rdflib' 'python-pyrdfa3' 'python-mf2py' 'python-six' 'python-w3lib' 'python-html-text' 'python-jstyleson') | ||
12 | makedepends=('python-setuptools') | ||
13 | source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") | ||
14 | sha256sums=('9ad821c0f87ce8096d72753e5cbdfbace72569aef298b0ee9b2a46ecb9bc46f3') | ||
15 | |||
16 | build() { | ||
17 | cd "${_pkgname}-${pkgver}" | ||
18 | python setup.py build | ||
19 | } | ||
20 | |||
21 | package() { | ||
22 | cd "${_pkgname}-${pkgver}" | ||
23 | python setup.py install --root="$pkgdir" --optimize=1 | ||
24 | install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/" | ||
25 | } | ||