diff options
Diffstat (limited to 'popcorntime-bin')
-rw-r--r-- | popcorntime-bin/.SRCINFO | 23 | ||||
-rw-r--r-- | popcorntime-bin/.gitignore | 4 | ||||
-rw-r--r-- | popcorntime-bin/PKGBUILD | 61 | ||||
-rw-r--r-- | popcorntime-bin/popcorntime.desktop | 9 |
4 files changed, 97 insertions, 0 deletions
diff --git a/popcorntime-bin/.SRCINFO b/popcorntime-bin/.SRCINFO new file mode 100644 index 0000000..37710d8 --- /dev/null +++ b/popcorntime-bin/.SRCINFO | |||
@@ -0,0 +1,23 @@ | |||
1 | pkgbase = popcorntime-bin | ||
2 | pkgdesc = Stream free movies and TV shows from torrents | ||
3 | pkgver = 0.4.9 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/popcorn-official/popcorn-desktop | ||
6 | arch = x86_64 | ||
7 | license = GPL3 | ||
8 | makedepends = unzip | ||
9 | depends = nss | ||
10 | depends = ttf-font | ||
11 | depends = libxss | ||
12 | depends = gtk3 | ||
13 | provides = popcorntime | ||
14 | provides = popcorntime-ce | ||
15 | conflicts = popcorntime | ||
16 | conflicts = popcorntime-ce | ||
17 | options = !strip | ||
18 | source = https://github.com/popcorn-official/popcorn-desktop/releases/download/v0.4.9/Popcorn-Time-0.4.9-linux64.zip | ||
19 | source = popcorntime.desktop | ||
20 | sha256sums = 71b28be5b8307990ffc9f8bff0a4b42fb45a85af0f4c7a889b8a923c589d8d47 | ||
21 | sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334 | ||
22 | |||
23 | pkgname = popcorntime-bin | ||
diff --git a/popcorntime-bin/.gitignore b/popcorntime-bin/.gitignore new file mode 100644 index 0000000..a954168 --- /dev/null +++ b/popcorntime-bin/.gitignore | |||
@@ -0,0 +1,4 @@ | |||
1 | *.log | ||
2 | Popcorn-Time-*-linux64.zip | ||
3 | popcorntime-bin-*.pkg.tar.xz | ||
4 | popcorntime-bin-*.pkg.tar.zst | ||
diff --git a/popcorntime-bin/PKGBUILD b/popcorntime-bin/PKGBUILD new file mode 100644 index 0000000..c59e8cc --- /dev/null +++ b/popcorntime-bin/PKGBUILD | |||
@@ -0,0 +1,61 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor : Barfin | ||
3 | # Contributor: Kostis Karantias <kkarantias [at] gmail [dot] com> | ||
4 | # Contributor: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com> | ||
5 | # Contributor: Bastien Traverse <firstname at lastname dot email> | ||
6 | # Contributor: Ricardo Funke <ricardo [at] gmail [dot] com> | ||
7 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> | ||
8 | # Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> | ||
9 | # Contributor: Eric Engestrom <aur [at] engestrom [dot] ch> | ||
10 | # Contributor: Ricardo Band <me [at] xengi [dot] de> | ||
11 | # Contributor: Axilleas Pipinellis (aka axil42) <axilleas [at] archlinux [dot] info> | ||
12 | # Contributor: UshakovVasilii <UshakovVasilii [at] yahoo [dot] com> | ||
13 | # Contributor: Giulio Fidente <gfidente [at] gmail [dot] com> | ||
14 | # Contributor: xantares <xantares09 [at] hotmail [dot] com> | ||
15 | # Contributor: petterk <stifler3k [at] hotmail [dot] com> | ||
16 | # Contributor: Stephan Springer <buzo+arch (at) Lini (dot) de> | ||
17 | |||
18 | pkgname=popcorntime-bin | ||
19 | _pkgname=popcorntime | ||
20 | pkgver=0.4.9 | ||
21 | pkgrel=1 | ||
22 | pkgdesc="Stream free movies and TV shows from torrents" | ||
23 | arch=('x86_64') | ||
24 | url="https://github.com/popcorn-official/popcorn-desktop" | ||
25 | license=('GPL3') | ||
26 | depends=('nss' 'ttf-font' 'libxss' 'gtk3') | ||
27 | makedepends=('unzip') | ||
28 | provides=('popcorntime' 'popcorntime-ce') | ||
29 | conflicts=('popcorntime' 'popcorntime-ce') | ||
30 | options=('!strip') | ||
31 | _zipfile="Popcorn-Time-${pkgver}-linux64.zip" | ||
32 | source=("https://github.com/popcorn-official/popcorn-desktop/releases/download/v${pkgver}/$_zipfile" | ||
33 | "${_pkgname}.desktop" ) | ||
34 | sha256sums=('fcf9c4d6ccd4fccaf7668707b16dcdd78d043b2d4f2a049f0edaf7afd8bb34f1' | ||
35 | '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') | ||
36 | |||
37 | package() { | ||
38 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" | ||
39 | install -dm755 "${pkgdir}/usr/bin" | ||
40 | |||
41 | # Link to program | ||
42 | ln -s "../share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}" | ||
43 | |||
44 | # Desktop file | ||
45 | install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop" | ||
46 | |||
47 | # Icon | ||
48 | install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png" | ||
49 | |||
50 | # Remove makepkg-created symlinks before copying content | ||
51 | rm "$_zipfile" "${_pkgname}.desktop" | ||
52 | |||
53 | # Copy complete content of source archive to /usr/share/${_pkgname} | ||
54 | cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}" | ||
55 | |||
56 | # Fix permissions | ||
57 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \; | ||
58 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \; | ||
59 | } | ||
60 | sha256sums=('71b28be5b8307990ffc9f8bff0a4b42fb45a85af0f4c7a889b8a923c589d8d47' | ||
61 | '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') | ||
diff --git a/popcorntime-bin/popcorntime.desktop b/popcorntime-bin/popcorntime.desktop new file mode 100644 index 0000000..3b39b63 --- /dev/null +++ b/popcorntime-bin/popcorntime.desktop | |||
@@ -0,0 +1,9 @@ | |||
1 | [Desktop Entry] | ||
2 | Name=Popcorn Time | ||
3 | Comment=Watch Movies and TV Shows instantly | ||
4 | Exec=popcorntime %U | ||
5 | Icon=popcorntime | ||
6 | MimeType=application/x-bittorrent;x-scheme-handler/magnet; | ||
7 | StartupNotify=false | ||
8 | Categories=AudioVideo;Video;Network;Player;P2P; | ||
9 | Type=Application | ||