summaryrefslogtreecommitdiffstats
path: root/popcorntime-bin
diff options
context:
space:
mode:
Diffstat (limited to 'popcorntime-bin')
-rw-r--r--popcorntime-bin/.SRCINFO21
-rw-r--r--popcorntime-bin/.gitignore4
-rw-r--r--popcorntime-bin/PKGBUILD59
-rw-r--r--popcorntime-bin/popcorntime.desktop9
4 files changed, 93 insertions, 0 deletions
diff --git a/popcorntime-bin/.SRCINFO b/popcorntime-bin/.SRCINFO
new file mode 100644
index 0000000..4b2b470
--- /dev/null
+++ b/popcorntime-bin/.SRCINFO
@@ -0,0 +1,21 @@
1pkgbase = popcorntime-bin
2 pkgdesc = Stream free movies and TV shows from torrents
3 pkgver = 0.5.1
4 pkgrel = 2
5 url = https://github.com/popcorn-official/popcorn-desktop
6 arch = x86_64
7 license = GPL3
8 makedepends = unzip
9 depends = nss
10 depends = ttf-font
11 depends = libxss
12 depends = gtk3
13 provides = popcorntime
14 conflicts = popcorntime
15 options = !strip
16 source = https://github.com/popcorn-official/popcorn-desktop/releases/download/v0.5.1/Popcorn-Time-0.5.1-linux64.zip
17 source = popcorntime.desktop
18 sha256sums = 942b088a8476e761963fffb0370913c393cb49a97f33dc7a9a547f10a39dfe1b
19 sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334
20
21pkgname = popcorntime-bin
diff --git a/popcorntime-bin/.gitignore b/popcorntime-bin/.gitignore
new file mode 100644
index 0000000..a954168
--- /dev/null
+++ b/popcorntime-bin/.gitignore
@@ -0,0 +1,4 @@
1*.log
2Popcorn-Time-*-linux64.zip
3popcorntime-bin-*.pkg.tar.xz
4popcorntime-bin-*.pkg.tar.zst
diff --git a/popcorntime-bin/PKGBUILD b/popcorntime-bin/PKGBUILD
new file mode 100644
index 0000000..43deb61
--- /dev/null
+++ b/popcorntime-bin/PKGBUILD
@@ -0,0 +1,59 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Barfin
3# Contributor: Kostis Karantias <kkarantias [at] gmail [dot] com>
4# Contributor: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com>
5# Contributor: Bastien Traverse <firstname at lastname dot email>
6# Contributor: Ricardo Funke <ricardo [at] gmail [dot] com>
7# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
8# Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com>
9# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
10# Contributor: Ricardo Band <me [at] xengi [dot] de>
11# Contributor: Axilleas Pipinellis (aka axil42) <axilleas [at] archlinux [dot] info>
12# Contributor: UshakovVasilii <UshakovVasilii [at] yahoo [dot] com>
13# Contributor: Giulio Fidente <gfidente [at] gmail [dot] com>
14# Contributor: xantares <xantares09 [at] hotmail [dot] com>
15# Contributor: petterk <stifler3k [at] hotmail [dot] com>
16# Contributor: Stephan Springer <buzo+arch (at) Lini (dot) de>
17
18pkgname=popcorntime-bin
19_pkgname=popcorntime
20pkgver=0.5.1
21pkgrel=2
22pkgdesc="Stream free movies and TV shows from torrents"
23arch=('x86_64')
24url="https://github.com/popcorn-official/popcorn-desktop"
25license=('GPL3')
26depends=('nss' 'ttf-font' 'libxss' 'gtk3')
27makedepends=('unzip')
28provides=('popcorntime')
29conflicts=('popcorntime')
30options=('!strip')
31_zipfile="Popcorn-Time-${pkgver}-linux64.zip"
32source=("https://github.com/popcorn-official/popcorn-desktop/releases/download/v${pkgver}/$_zipfile"
33 "${_pkgname}.desktop" )
34sha256sums=('942b088a8476e761963fffb0370913c393cb49a97f33dc7a9a547f10a39dfe1b'
35 '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
36
37package() {
38 install -dm755 "${pkgdir}/usr/share/${_pkgname}"
39 install -dm755 "${pkgdir}/usr/bin"
40
41 # Link to program
42 ln -s "../share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}"
43
44 # Desktop file
45 install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
46
47 # Icon
48 install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
49
50 # Remove makepkg-created symlinks before copying content
51 rm "$_zipfile" "${_pkgname}.desktop"
52
53 # Copy complete content of source archive to /usr/share/${_pkgname}
54 cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}"
55
56 # Fix permissions
57 find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \;
58 find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \;
59}
diff --git a/popcorntime-bin/popcorntime.desktop b/popcorntime-bin/popcorntime.desktop
new file mode 100644
index 0000000..3b39b63
--- /dev/null
+++ b/popcorntime-bin/popcorntime.desktop
@@ -0,0 +1,9 @@
1[Desktop Entry]
2Name=Popcorn Time
3Comment=Watch Movies and TV Shows instantly
4Exec=popcorntime %U
5Icon=popcorntime
6MimeType=application/x-bittorrent;x-scheme-handler/magnet;
7StartupNotify=false
8Categories=AudioVideo;Video;Network;Player;P2P;
9Type=Application