diff options
Diffstat (limited to 'popcorntime-bin/PKGBUILD')
-rw-r--r-- | popcorntime-bin/PKGBUILD | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/popcorntime-bin/PKGBUILD b/popcorntime-bin/PKGBUILD new file mode 100644 index 0000000..43deb61 --- /dev/null +++ b/popcorntime-bin/PKGBUILD | |||
@@ -0,0 +1,59 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Barfin | ||
3 | # Contributor: Kostis Karantias <kkarantias [at] gmail [dot] com> | ||
4 | # Contributor: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com> | ||
5 | # Contributor: Bastien Traverse <firstname at lastname dot email> | ||
6 | # Contributor: Ricardo Funke <ricardo [at] gmail [dot] com> | ||
7 | # Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu> | ||
8 | # Contributor: Iwan Timmer <irtimmer [at] gmail [dot] com> | ||
9 | # Contributor: Eric Engestrom <aur [at] engestrom [dot] ch> | ||
10 | # Contributor: Ricardo Band <me [at] xengi [dot] de> | ||
11 | # Contributor: Axilleas Pipinellis (aka axil42) <axilleas [at] archlinux [dot] info> | ||
12 | # Contributor: UshakovVasilii <UshakovVasilii [at] yahoo [dot] com> | ||
13 | # Contributor: Giulio Fidente <gfidente [at] gmail [dot] com> | ||
14 | # Contributor: xantares <xantares09 [at] hotmail [dot] com> | ||
15 | # Contributor: petterk <stifler3k [at] hotmail [dot] com> | ||
16 | # Contributor: Stephan Springer <buzo+arch (at) Lini (dot) de> | ||
17 | |||
18 | pkgname=popcorntime-bin | ||
19 | _pkgname=popcorntime | ||
20 | pkgver=0.5.1 | ||
21 | pkgrel=2 | ||
22 | pkgdesc="Stream free movies and TV shows from torrents" | ||
23 | arch=('x86_64') | ||
24 | url="https://github.com/popcorn-official/popcorn-desktop" | ||
25 | license=('GPL3') | ||
26 | depends=('nss' 'ttf-font' 'libxss' 'gtk3') | ||
27 | makedepends=('unzip') | ||
28 | provides=('popcorntime') | ||
29 | conflicts=('popcorntime') | ||
30 | options=('!strip') | ||
31 | _zipfile="Popcorn-Time-${pkgver}-linux64.zip" | ||
32 | source=("https://github.com/popcorn-official/popcorn-desktop/releases/download/v${pkgver}/$_zipfile" | ||
33 | "${_pkgname}.desktop" ) | ||
34 | sha256sums=('942b088a8476e761963fffb0370913c393cb49a97f33dc7a9a547f10a39dfe1b' | ||
35 | '4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334') | ||
36 | |||
37 | package() { | ||
38 | install -dm755 "${pkgdir}/usr/share/${_pkgname}" | ||
39 | install -dm755 "${pkgdir}/usr/bin" | ||
40 | |||
41 | # Link to program | ||
42 | ln -s "../share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}" | ||
43 | |||
44 | # Desktop file | ||
45 | install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop" | ||
46 | |||
47 | # Icon | ||
48 | install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png" | ||
49 | |||
50 | # Remove makepkg-created symlinks before copying content | ||
51 | rm "$_zipfile" "${_pkgname}.desktop" | ||
52 | |||
53 | # Copy complete content of source archive to /usr/share/${_pkgname} | ||
54 | cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}" | ||
55 | |||
56 | # Fix permissions | ||
57 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \; | ||
58 | find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \; | ||
59 | } | ||