diff options
Diffstat (limited to 'polybar-spotify-git')
-rw-r--r-- | polybar-spotify-git/.SRCINFO | 14 | ||||
-rw-r--r-- | polybar-spotify-git/PKGBUILD | 29 |
2 files changed, 43 insertions, 0 deletions
diff --git a/polybar-spotify-git/.SRCINFO b/polybar-spotify-git/.SRCINFO new file mode 100644 index 0000000..1b2bed7 --- /dev/null +++ b/polybar-spotify-git/.SRCINFO | |||
@@ -0,0 +1,14 @@ | |||
1 | pkgbase = polybar-spotify-git | ||
2 | pkgdesc = Spotify artist and song module for Polybar | ||
3 | pkgver = r42.9bc2997 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/Jvanrhijn/polybar-spotify | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | makedepends = git | ||
9 | depends = python | ||
10 | depends = python-dbus | ||
11 | source = polybar-spotify::git+https://github.com/Jvanrhijn/polybar-spotify.git | ||
12 | sha256sums = SKIP | ||
13 | |||
14 | pkgname = polybar-spotify-git | ||
diff --git a/polybar-spotify-git/PKGBUILD b/polybar-spotify-git/PKGBUILD new file mode 100644 index 0000000..73e8b30 --- /dev/null +++ b/polybar-spotify-git/PKGBUILD | |||
@@ -0,0 +1,29 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: timescam <rex.ky.ng@gmail.com> | ||
3 | |||
4 | _pkgname=polybar-spotify | ||
5 | pkgname=${_pkgname}-git | ||
6 | pkgver=r42.9bc2997 | ||
7 | pkgrel=1 | ||
8 | pkgdesc='Spotify artist and song module for Polybar' | ||
9 | arch=(any) | ||
10 | url=https://github.com/Jvanrhijn/${_pkgname} | ||
11 | license=('MIT') | ||
12 | depends=('python' 'python-dbus') | ||
13 | makedepends=(git) | ||
14 | source=("${_pkgname}::git+${url}.git") | ||
15 | sha256sums=('SKIP') | ||
16 | |||
17 | pkgver() { | ||
18 | cd ${_pkgname} | ||
19 | set -o pipefail | ||
20 | git describe --long 2> /dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' || | ||
21 | printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" | ||
22 | } | ||
23 | |||
24 | package() { | ||
25 | cd ${_pkgname} | ||
26 | install -Dm644 README.md "${pkgdir}"/usr/share/doc/${_pkgname}/README.md | ||
27 | install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE | ||
28 | install -Dm755 spotify_status.py "${pkgdir}"/usr/share/polybar/scripts/spotify_status.py | ||
29 | } | ||