aboutsummaryrefslogtreecommitdiffstats
path: root/polybar-spotify-git/PKGBUILD
diff options
context:
space:
mode:
diffstat (limited to 'polybar-spotify-git/PKGBUILD')
-rw-r--r--polybar-spotify-git/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/polybar-spotify-git/PKGBUILD b/polybar-spotify-git/PKGBUILD
new file mode 100644
index 0000000..73e8b30
--- /dev/null
+++ b/polybar-spotify-git/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: timescam <rex.ky.ng@gmail.com>
3
4_pkgname=polybar-spotify
5pkgname=${_pkgname}-git
6pkgver=r42.9bc2997
7pkgrel=1
8pkgdesc='Spotify artist and song module for Polybar'
9arch=(any)
10url=https://github.com/Jvanrhijn/${_pkgname}
11license=('MIT')
12depends=('python' 'python-dbus')
13makedepends=(git)
14source=("${_pkgname}::git+${url}.git")
15sha256sums=('SKIP')
16
17pkgver() {
18 cd ${_pkgname}
19 set -o pipefail
20 git describe --long 2> /dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
21 printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
22}
23
24package() {
25 cd ${_pkgname}
26 install -Dm644 README.md "${pkgdir}"/usr/share/doc/${_pkgname}/README.md
27 install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE
28 install -Dm755 spotify_status.py "${pkgdir}"/usr/share/polybar/scripts/spotify_status.py
29}