diff options
Diffstat (limited to 'pfetch')
-rw-r--r-- | pfetch/.SRCINFO | 13 | ||||
-rw-r--r-- | pfetch/.gitignore | 3 | ||||
-rw-r--r-- | pfetch/PKGBUILD | 20 |
3 files changed, 36 insertions, 0 deletions
diff --git a/pfetch/.SRCINFO b/pfetch/.SRCINFO new file mode 100644 index 0000000..d6e47e6 --- /dev/null +++ b/pfetch/.SRCINFO | |||
@@ -0,0 +1,13 @@ | |||
1 | pkgbase = pfetch | ||
2 | pkgdesc = A pretty system information tool written in POSIX sh. | ||
3 | pkgver = 1.2.0 | ||
4 | pkgrel = 1 | ||
5 | url = https://github.com/Un1q32/pfetch | ||
6 | arch = any | ||
7 | license = MIT | ||
8 | provides = pfetch | ||
9 | conflicts = pfetch-git | ||
10 | source = pfetch-1.2.0.tar.gz::https://github.com/Un1q32/pfetch/archive/1.2.0.tar.gz | ||
11 | sha256sums = 89235ecb2082a6fb2d25d595ec28f1d9e665903679726166b78488e8c43b1513 | ||
12 | |||
13 | pkgname = pfetch | ||
diff --git a/pfetch/.gitignore b/pfetch/.gitignore new file mode 100644 index 0000000..8d78c83 --- /dev/null +++ b/pfetch/.gitignore | |||
@@ -0,0 +1,3 @@ | |||
1 | pkg/ | ||
2 | src/ | ||
3 | *.tar* | ||
diff --git a/pfetch/PKGBUILD b/pfetch/PKGBUILD new file mode 100644 index 0000000..35fff64 --- /dev/null +++ b/pfetch/PKGBUILD | |||
@@ -0,0 +1,20 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: Qontinuum <qontinuum.dev@protonmail.ch> | ||
3 | # Contributor: Caio Novais <caionov08 at gmail dot com> | ||
4 | |||
5 | pkgname=pfetch | ||
6 | pkgver=1.2.0 | ||
7 | pkgrel=1 | ||
8 | pkgdesc="A pretty system information tool written in POSIX sh." | ||
9 | arch=('any') | ||
10 | url="https://github.com/Un1q32/$pkgname" | ||
11 | license=('MIT') | ||
12 | provides=("$pkgname") | ||
13 | conflicts=('pfetch-git') | ||
14 | source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz") | ||
15 | sha256sums=('89235ecb2082a6fb2d25d595ec28f1d9e665903679726166b78488e8c43b1513') | ||
16 | |||
17 | package() { | ||
18 | install -Dm755 "$srcdir/$pkgname-$pkgver/pfetch" "$pkgdir/usr/bin/pfetch" | ||
19 | install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
20 | } | ||