summaryrefslogtreecommitdiffstats
path: root/pfetch
diff options
context:
space:
mode:
Diffstat (limited to 'pfetch')
-rw-r--r--pfetch/.SRCINFO14
-rw-r--r--pfetch/.gitignore3
-rw-r--r--pfetch/PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/pfetch/.SRCINFO b/pfetch/.SRCINFO
new file mode 100644
index 0000000..daffbc0
--- /dev/null
+++ b/pfetch/.SRCINFO
@@ -0,0 +1,14 @@
1pkgbase = pfetch
2 pkgdesc = A pretty system information tool written in POSIX sh.
3 pkgver = 0.6.0
4 pkgrel = 3
5 url = https://github.com/dylanaraps/pfetch
6 arch = any
7 license = MIT
8 provides = pfetch
9 conflicts = pfetch-git
10 source = pfetch-0.6.0.tar.gz::https://github.com/dylanaraps/pfetch/archive/0.6.0.tar.gz
11 b2sums = 300f6f44f9306df4f438227a6f35bd54f50e477b950a45d63656f7c460cfc30a8b44ebdb3d5fdcf1e808e3b8e8e69e14088ff73a5da4485abf694893f2cc53f3
12
13pkgname = pfetch
14
diff --git a/pfetch/.gitignore b/pfetch/.gitignore
new file mode 100644
index 0000000..8d78c83
--- /dev/null
+++ b/pfetch/.gitignore
@@ -0,0 +1,3 @@
1pkg/
2src/
3*.tar*
diff --git a/pfetch/PKGBUILD b/pfetch/PKGBUILD
new file mode 100644
index 0000000..e3a1ab5
--- /dev/null
+++ b/pfetch/PKGBUILD
@@ -0,0 +1,19 @@
1# Maintainer: Qontinuum <qontinuum.dev@protonmail.ch>
2# Contributor: Caio Novais <caionov08 at gmail dot com>
3
4pkgname=pfetch
5pkgver=0.6.0
6pkgrel=3
7pkgdesc="A pretty system information tool written in POSIX sh."
8arch=('any')
9url="https://github.com/dylanaraps/$pkgname"
10license=('MIT')
11provides=("$pkgname")
12conflicts=('pfetch-git')
13source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
14b2sums=('300f6f44f9306df4f438227a6f35bd54f50e477b950a45d63656f7c460cfc30a8b44ebdb3d5fdcf1e808e3b8e8e69e14088ff73a5da4485abf694893f2cc53f3')
15
16package() {
17 install -Dm755 "$srcdir/$pkgname-$pkgver/pfetch" "$pkgdir/usr/bin/pfetch"
18 install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
19}