summaryrefslogtreecommitdiffstats
path: root/pfetch
diff options
context:
space:
mode:
Diffstat (limited to 'pfetch')
-rw-r--r--pfetch/.SRCINFO13
-rw-r--r--pfetch/.gitignore3
-rw-r--r--pfetch/PKGBUILD20
3 files changed, 36 insertions, 0 deletions
diff --git a/pfetch/.SRCINFO b/pfetch/.SRCINFO
new file mode 100644
index 0000000..8131e73
--- /dev/null
+++ b/pfetch/.SRCINFO
@@ -0,0 +1,13 @@
1pkgbase = pfetch
2 pkgdesc = A pretty system information tool written in POSIX sh.
3 pkgver = 1.6.0
4 pkgrel = 1
5 url = https://github.com/Un1q32/pfetch
6 arch = any
7 license = MIT
8 provides = pfetch
9 conflicts = pfetch-git
10 source = pfetch-1.6.0.tar.gz::https://github.com/Un1q32/pfetch/archive/1.6.0.tar.gz
11 sha256sums = 06190a043677ae7c6d3fbdd2049e32cee440e733cc50117d56f96d14bf3918b5
12
13pkgname = pfetch
diff --git a/pfetch/.gitignore b/pfetch/.gitignore
new file mode 100644
index 0000000..8d78c83
--- /dev/null
+++ b/pfetch/.gitignore
@@ -0,0 +1,3 @@
1pkg/
2src/
3*.tar*
diff --git a/pfetch/PKGBUILD b/pfetch/PKGBUILD
new file mode 100644
index 0000000..ee443a3
--- /dev/null
+++ b/pfetch/PKGBUILD
@@ -0,0 +1,20 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Qontinuum <qontinuum.dev@protonmail.ch>
3# Contributor: Caio Novais <caionov08 at gmail dot com>
4
5pkgname=pfetch
6pkgver=1.6.0
7pkgrel=1
8pkgdesc="A pretty system information tool written in POSIX sh."
9arch=('any')
10url="https://github.com/Un1q32/$pkgname"
11license=('MIT')
12provides=("$pkgname")
13conflicts=('pfetch-git')
14source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
15sha256sums=('06190a043677ae7c6d3fbdd2049e32cee440e733cc50117d56f96d14bf3918b5')
16
17package() {
18 install -Dm755 "$srcdir/$pkgname-$pkgver/pfetch" "$pkgdir/usr/bin/pfetch"
19 install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
20}