summaryrefslogtreecommitdiffstats
path: root/ouch
diff options
context:
space:
mode:
Diffstat (limited to 'ouch')
-rw-r--r--ouch/.SRCINFO6
-rw-r--r--ouch/PKGBUILD5
2 files changed, 5 insertions, 6 deletions
diff --git a/ouch/.SRCINFO b/ouch/.SRCINFO
index 27bd7fc..9ab8a60 100644
--- a/ouch/.SRCINFO
+++ b/ouch/.SRCINFO
@@ -1,6 +1,6 @@
1pkgbase = ouch 1pkgbase = ouch
2 pkgdesc = Painless compression and decompression in the terminal 2 pkgdesc = Painless compression and decompression in the terminal
3 pkgver = 0.4.0 3 pkgver = 0.4.1
4 pkgrel = 2 4 pkgrel = 2
5 url = https://github.com/ouch-org/ouch 5 url = https://github.com/ouch-org/ouch
6 arch = x86_64 6 arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = ouch
8 makedepends = cargo 8 makedepends = cargo
9 conflicts = ouch-git 9 conflicts = ouch-git
10 conflicts = ouch-bin 10 conflicts = ouch-bin
11 source = ouch-0.4.0.tar.gz::https://github.com/ouch-org/ouch/archive/refs/tags/0.4.0.tar.gz 11 source = ouch-0.4.1.tar.gz::https://github.com/ouch-org/ouch/archive/refs/tags/0.4.1.tar.gz
12 sha256sums = 3e126f00e1ad82ef4abfd28f86dac53b366a29de6a70359e734ecc8748f580fc 12 sha256sums = b0fcd6bbe6c66544b5bf1167d72605427c5cc6afae564f23f3eff5ea22b01b79
13 13
14pkgname = ouch 14pkgname = ouch
diff --git a/ouch/PKGBUILD b/ouch/PKGBUILD
index 0d3cfee..349b337 100644
--- a/ouch/PKGBUILD
+++ b/ouch/PKGBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com> 1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2 2
3pkgname=ouch 3pkgname=ouch
4pkgver=0.4.0 4pkgver=0.4.1
5pkgrel=2 5pkgrel=2
6pkgdesc="Painless compression and decompression in the terminal" 6pkgdesc="Painless compression and decompression in the terminal"
7arch=('x86_64') 7arch=('x86_64')
@@ -14,8 +14,6 @@ sha256sums=('3e126f00e1ad82ef4abfd28f86dac53b366a29de6a70359e734ecc8748f580fc')
14 14
15prepare() { 15prepare() {
16 cd "$srcdir/$pkgname-$pkgver" 16 cd "$srcdir/$pkgname-$pkgver"
17 # TODO: Remove on next release <27-11-22, yigit> #
18 rm -f rust-toolchain
19 cargo fetch --locked --target "$CARCH-unknown-linux-gnu" 17 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
20} 18}
21 19
@@ -51,3 +49,4 @@ package() {
51 install -Dm0644 "${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish" 49 install -Dm0644 "${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
52 install -Dm0644 "_${pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}" 50 install -Dm0644 "_${pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
53} 51}
52sha256sums=('b0fcd6bbe6c66544b5bf1167d72605427c5cc6afae564f23f3eff5ea22b01b79')