summaryrefslogtreecommitdiffstats
path: root/ouch-git
diff options
context:
space:
mode:
Diffstat (limited to 'ouch-git')
-rw-r--r--ouch-git/.SRCINFO16
-rw-r--r--ouch-git/PKGBUILD58
2 files changed, 74 insertions, 0 deletions
diff --git a/ouch-git/.SRCINFO b/ouch-git/.SRCINFO
new file mode 100644
index 0000000..21b6928
--- /dev/null
+++ b/ouch-git/.SRCINFO
@@ -0,0 +1,16 @@
1pkgbase = ouch-git
2 pkgdesc = Painless compression and decompression in the terminal (git version)
3 pkgver = r693.d4f181b
4 pkgrel = 1
5 url = https://github.com/ouch-org/ouch/
6 arch = x86_64
7 license = MIT
8 makedepends = git
9 makedepends = cargo
10 provides = ouch
11 conflicts = ouch
12 conflicts = ouch-bin
13 source = ouch::git+https://github.com/ouch-org/ouch/
14 sha256sums = SKIP
15
16pkgname = ouch-git
diff --git a/ouch-git/PKGBUILD b/ouch-git/PKGBUILD
new file mode 100644
index 0000000..7a33f12
--- /dev/null
+++ b/ouch-git/PKGBUILD
@@ -0,0 +1,58 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=ouch-git
4_pkgname=${pkgname%-git}
5pkgver=r693.d4f181b
6pkgrel=1
7pkgdesc="Painless compression and decompression in the terminal (git version)"
8arch=('x86_64')
9url="https://github.com/ouch-org/ouch/"
10license=('MIT')
11makedepends=('git' 'cargo')
12provides=(${_pkgname})
13conflicts=(${_pkgname} ${_pkgname}-bin)
14source=("${_pkgname}::git+${url}")
15sha256sums=('SKIP')
16
17pkgver() {
18 cd "$srcdir/${_pkgname}"
19 printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
20}
21
22prepare() {
23 cd "$srcdir/${_pkgname}"
24 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
25}
26
27build() {
28 cd "$srcdir/${_pkgname}"
29 export RUSTUP_TOOLCHAIN=stable
30 export CARGO_TARGET_DIR=target
31 OUCH_ARTIFACTS_FOLDER=artifacts cargo build --frozen --release --all-features
32}
33
34check() {
35 cd "$srcdir/${_pkgname}"
36 export RUSTUP_TOOLCHAIN=stable
37 cargo test --frozen --all-features
38}
39
40package() {
41 cd "$srcdir/${_pkgname}"
42
43 install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}"
44 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
45
46 cd artifacts
47
48 # install manpages
49 install -Dm0644 "${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1"
50 install -Dm0644 "${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1"
51 install -Dm0644 "${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1"
52 install -Dm0644 "${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1"
53
54 # install shell completions
55 install -Dm0644 "${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
56 install -Dm0644 "${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
57 install -Dm0644 "_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
58}