summaryrefslogtreecommitdiffstats
path: root/ouch-bin
diff options
context:
space:
mode:
Diffstat (limited to 'ouch-bin')
-rw-r--r--ouch-bin/.SRCINFO16
-rw-r--r--ouch-bin/PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/ouch-bin/.SRCINFO b/ouch-bin/.SRCINFO
new file mode 100644
index 0000000..6247c1d
--- /dev/null
+++ b/ouch-bin/.SRCINFO
@@ -0,0 +1,16 @@
1pkgbase = ouch-bin
2 pkgdesc = Painless compression and decompression in the terminal (binary release)
3 pkgver = 0.3.1
4 pkgrel = 1
5 url = https://github.com/ouch-org/ouch
6 arch = x86_64
7 license = MIT
8 provides = ouch
9 conflicts = ouch
10 conflicts = ouch-git
11 source = ouch::https://github.com/ouch-org/ouch/releases/download/0.3.1/ouch-x86_64-linux-musl
12 source = LICENSE::https://raw.githubusercontent.com/ouch-org/ouch/master/LICENSE
13 sha256sums = 48843b18aee48273e60456267c408163d51df046ad79a6cdd99c75c45cb79afe
14 sha256sums = f082ccc8a66b3fdbeb6d53d5fe084934fc6f480a9d1d9243d2c5d9e45ec76938
15
16pkgname = ouch-bin
diff --git a/ouch-bin/PKGBUILD b/ouch-bin/PKGBUILD
new file mode 100644
index 0000000..9bc3dfd
--- /dev/null
+++ b/ouch-bin/PKGBUILD
@@ -0,0 +1,21 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2
3pkgname=ouch-bin
4_pkgname=${pkgname%-bin}
5pkgver=0.3.1
6pkgrel=1
7pkgdesc="Painless compression and decompression in the terminal (binary release)"
8arch=('x86_64')
9url="https://github.com/ouch-org/ouch"
10license=('MIT')
11provides=(${_pkgname})
12conflicts=(${_pkgname} ${_pkgname}-git)
13source=("${_pkgname}::${url}/releases/download/${pkgver}/ouch-x86_64-linux-musl"
14 "LICENSE::https://raw.githubusercontent.com/ouch-org/ouch/master/LICENSE")
15sha256sums=('48843b18aee48273e60456267c408163d51df046ad79a6cdd99c75c45cb79afe'
16 'f082ccc8a66b3fdbeb6d53d5fe084934fc6f480a9d1d9243d2c5d9e45ec76938')
17
18package() {
19 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
20 install -Dvm755 "${_pkgname}" -t "${pkgdir}/usr/bin"
21}