diff options
Diffstat (limited to 'ouch-bin/PKGBUILD')
-rw-r--r-- | ouch-bin/PKGBUILD | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/ouch-bin/PKGBUILD b/ouch-bin/PKGBUILD new file mode 100644 index 0000000..0641836 --- /dev/null +++ b/ouch-bin/PKGBUILD | |||
@@ -0,0 +1,40 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | |||
3 | pkgname=ouch-bin | ||
4 | _pkgname=${pkgname%-bin} | ||
5 | pkgver=0.4.0 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="Painless compression and decompression in the terminal (binary release)" | ||
8 | arch=('x86_64') | ||
9 | url="https://github.com/ouch-org/ouch" | ||
10 | license=('MIT') | ||
11 | provides=(${_pkgname}) | ||
12 | conflicts=(${_pkgname} ${_pkgname}-git) | ||
13 | source=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/ouch-x86_64-unknown-linux-gnu.tar.gz") | ||
14 | sha256sums=('4b03c6a54b12e2038600cfb450aebac70bd9516fc9bf50a78c93f93fef75e60b') | ||
15 | |||
16 | package() { | ||
17 | # Binary releaes is archived in a folder with a generic name, it is not ideal | ||
18 | # (e.g. aur helpers will complain about name clashes) | ||
19 | # So we fix it | ||
20 | cd "${srcdir}" | ||
21 | mkdir "${_pkgname}-${pkgver}" | ||
22 | mv "${srcdir}/ouch-x86_64-unknown-linux-gnu/"* "${_pkgname}-${pkgver}" | ||
23 | rmdir ouch-x86_64-unknown-linux-gnu | ||
24 | |||
25 | cd "${srcdir}/${_pkgname}-${pkgver}" | ||
26 | |||
27 | install -Dm0755 -t "${pkgdir}/usr/bin" "${_pkgname}" | ||
28 | install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE" | ||
29 | |||
30 | # install manpages | ||
31 | install -Dm0644 "man/${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1" | ||
32 | install -Dm0644 "man/${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1" | ||
33 | install -Dm0644 "man/${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1" | ||
34 | install -Dm0644 "man/${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1" | ||
35 | |||
36 | # install shell completions | ||
37 | install -Dm0644 "completions/${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}" | ||
38 | install -Dm0644 "completions/${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish" | ||
39 | install -Dm0644 "completions/_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}" | ||
40 | } | ||