diff options
Diffstat (limited to 'logisim-evolution/PKGBUILD')
-rw-r--r-- | logisim-evolution/PKGBUILD | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/logisim-evolution/PKGBUILD b/logisim-evolution/PKGBUILD new file mode 100644 index 0000000..f1023ae --- /dev/null +++ b/logisim-evolution/PKGBUILD | |||
@@ -0,0 +1,60 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: maniacata <maniaciachao at gmail dot com> | ||
3 | # Contributor: Marcin Wieczorek <marcin@marcin.co> | ||
4 | # Contributor: Martin Thierer <thierer@web.de> | ||
5 | # Contributor: Amy Wilson <awils_1[at]xsmail[dot]com> | ||
6 | # Contributor: Simon Doppler <dopsi[at]dopsi[dot]ch> | ||
7 | # Contributor: Agustin Borgna <hello[at]aborgna.com.ar> | ||
8 | # Contributor: Marcel Korpel <marcel[dot]korpel[at]gmail> | ||
9 | # Contributor: Renan Birck <renan.ee.ufsm at gmail.com> | ||
10 | |||
11 | pkgname=logisim-evolution | ||
12 | pkgver=3.7.1 | ||
13 | pkgrel=1 | ||
14 | pkgdesc='An educational tool for designing and simulating digital logic circuits (build from source)' | ||
15 | provides=('logisim-evolution') | ||
16 | conflicts=('logisim-evolution-git' 'logisim-evolution-bin') | ||
17 | arch=('any') | ||
18 | url="https://github.com/reds-heig/logisim-evolution" | ||
19 | license=('GPL3') | ||
20 | depends=('java-runtime>=16' 'hicolor-icon-theme') | ||
21 | makedepends=('java-environment>=16') | ||
22 | |||
23 | source=("${pkgname}-${pkgver}.tar.gz::https://github.com/reds-heig/logisim-evolution/archive/v${pkgver}.tar.gz" | ||
24 | "${pkgname}.sh") | ||
25 | sha256sums=('c073c8113159e8127cee818fad32d5fbe943b1072459f5a914fd99906f19f179' | ||
26 | 'd5975cc0025905ab8a8a451ce4362ba876bed88008d3a5b2c0a7f664a85da1ba') | ||
27 | |||
28 | install=$pkgname.install | ||
29 | |||
30 | build() { | ||
31 | cd "${srcdir}/${pkgname}-${pkgver}" | ||
32 | ./gradlew shadowJar | ||
33 | } | ||
34 | |||
35 | prepare() { | ||
36 | cd "${srcdir}/${pkgname}-${pkgver}" | ||
37 | sed -i 's/https/http/' "support/Flatpak/com.github.reds.LogisimEvolution.xml" | ||
38 | } | ||
39 | |||
40 | package() { | ||
41 | cd "${srcdir}/${pkgname}-${pkgver}" | ||
42 | install -Dm644 "build/libs/logisim-evolution-${pkgver}-all.jar" \ | ||
43 | "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar" | ||
44 | install -Dm644 "support/Flatpak/com.github.reds.LogisimEvolution.xml" \ | ||
45 | "${pkgdir}/usr/share/mime/packages/${pkgname}.xml" | ||
46 | install -Dm644 "support/Flatpak/com.github.reds.LogisimEvolution.desktop" \ | ||
47 | "${pkgdir}/usr/share/applications/${pkgname}.desktop" | ||
48 | |||
49 | for SIZE in 16 32 48 128 256; do | ||
50 | install -Dm644 \ | ||
51 | "src/main/resources/resources/logisim/img/logisim-icon-${SIZE}.png" \ | ||
52 | "${pkgdir}/usr/share/icons/hicolor/${SIZE}x${SIZE}/apps/${pkgname}.png" | ||
53 | done | ||
54 | |||
55 | install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}" | ||
56 | |||
57 | sed -e 's|Exec=.*|Exec=/usr/bin/logisim-evolution|' \ | ||
58 | -e 's|com.github.reds.LogisimEvolution|logisim-evolution|' \ | ||
59 | -i "${pkgdir}/usr/share/applications/${pkgname}.desktop" | ||
60 | } | ||