diff options
Diffstat (limited to 'ldm/PKGBUILD')
-rw-r--r-- | ldm/PKGBUILD | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/ldm/PKGBUILD b/ldm/PKGBUILD new file mode 100644 index 0000000..57f7228 --- /dev/null +++ b/ldm/PKGBUILD | |||
@@ -0,0 +1,31 @@ | |||
1 | # Maintainer: Yigit Sever <yigit at yigitsever dot com> | ||
2 | # Contributor: The Lemon Man | ||
3 | |||
4 | pkgname=ldm | ||
5 | pkgver=0.8 | ||
6 | pkgrel=1 | ||
7 | pkgdesc="A lightweight device mounter" | ||
8 | arch=('i686' 'x86_64' 'armv7h') | ||
9 | url="https://github.com/LemonBoy/ldm" | ||
10 | license=('MIT') | ||
11 | depends=('udev' 'util-linux' 'glib2') | ||
12 | provides=('ldm') | ||
13 | conflicts=('ldm-git') | ||
14 | install=$pkgname.install | ||
15 | source=("$pkgname-$pkgver.tar.gz"::"http://github.com/lemonboy/$pkgname/archive/v$pkgver.tar.gz") | ||
16 | sha256sums=('e471453e6ae9fa91d6150fe13c01587dd8e15a3f64665d0556ad7e8398dc46ef') | ||
17 | |||
18 | build() { | ||
19 | export PATH=$PATH:/usr/bin/core_perl | ||
20 | cd "$srcdir/$pkgname-$pkgver" | ||
21 | make | ||
22 | } | ||
23 | |||
24 | package() { | ||
25 | export PATH=$PATH:/usr/bin/core_perl | ||
26 | cd "$srcdir/$pkgname-$pkgver" | ||
27 | make PREFIX=/usr SBINDIR=/usr/bin DESTDIR="$pkgdir" install | ||
28 | |||
29 | install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
30 | } | ||
31 | |||