summaryrefslogtreecommitdiffstats
path: root/httpx-bin
diff options
context:
space:
mode:
Diffstat (limited to 'httpx-bin')
-rw-r--r--httpx-bin/.SRCINFO21
-rw-r--r--httpx-bin/.gitignore5
-rw-r--r--httpx-bin/PKGBUILD29
-rw-r--r--httpx-bin/httpx-bin.install9
4 files changed, 64 insertions, 0 deletions
diff --git a/httpx-bin/.SRCINFO b/httpx-bin/.SRCINFO
new file mode 100644
index 0000000..704d103
--- /dev/null
+++ b/httpx-bin/.SRCINFO
@@ -0,0 +1,21 @@
1pkgbase = httpx-bin
2 pkgdesc = Fast and multi-purpose HTTP toolkit
3 pkgver = 1.6.0
4 pkgrel = 1
5 url = https://github.com/projectdiscovery/httpx
6 install = httpx-bin.install
7 arch = x86_64
8 arch = armv6h
9 arch = aarch64
10 license = MIT
11 provides = httpx
12 conflicts = httpx
13 options = !strip
14 source_x86_64 = httpx-1.6.0-x86_64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.6.0/httpx_1.6.0_linux_amd64.zip
15 sha256sums_x86_64 = a209fbf6eb95cdfb3be9a90a1a57463c6dd1879a56ca32bb4a39cc55d9b0754d
16 source_armv6h = httpx-1.6.0-armv6.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.6.0/httpx_1.6.0_linux_arm.zip
17 sha256sums_armv6h = 93c4a9bf7c4a12394bf122be9d234dcd91ad28c3285cf029ab5ea4143bbd3e9b
18 source_aarch64 = httpx-1.6.0-aarch64.zip::https://github.com/projectdiscovery/httpx/releases/download/v1.6.0/httpx_1.6.0_linux_arm64.zip
19 sha256sums_aarch64 = 4fa8b296754c52da6fcc987870295e4159a15deeb3aa3a230f50cd208f72ef62
20
21pkgname = httpx-bin
diff --git a/httpx-bin/.gitignore b/httpx-bin/.gitignore
new file mode 100644
index 0000000..623d0e7
--- /dev/null
+++ b/httpx-bin/.gitignore
@@ -0,0 +1,5 @@
1*
2!.gitignore
3!.SRCINFO
4!PKGBUILD
5
diff --git a/httpx-bin/PKGBUILD b/httpx-bin/PKGBUILD
new file mode 100644
index 0000000..db49a40
--- /dev/null
+++ b/httpx-bin/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer: Yigit Sever <yigit at yigitsever dot com>
2# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
3
4_pkgname='httpx'
5pkgname="${_pkgname}-bin"
6pkgver=1.6.0
7pkgrel=1
8pkgdesc='Fast and multi-purpose HTTP toolkit'
9arch=('x86_64' 'armv6h' 'aarch64')
10url='https://github.com/projectdiscovery/httpx'
11license=('MIT')
12provides=("${_pkgname}")
13conflicts=("${_pkgname}")
14options=('!strip')
15install="${pkgname}.install"
16
17source_x86_64=("${_pkgname}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip")
18source_armv6h=("${_pkgname}-${pkgver}-armv6.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm.zip")
19source_aarch64=("${_pkgname}-${pkgver}-aarch64.zip::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.zip")
20
21sha256sums_x86_64=('a209fbf6eb95cdfb3be9a90a1a57463c6dd1879a56ca32bb4a39cc55d9b0754d')
22sha256sums_armv6h=('93c4a9bf7c4a12394bf122be9d234dcd91ad28c3285cf029ab5ea4143bbd3e9b')
23sha256sums_aarch64=('4fa8b296754c52da6fcc987870295e4159a15deeb3aa3a230f50cd208f72ef62')
24
25package() {
26 install -Dvm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}-toolkit"
27 install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
28 install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
29}
diff --git a/httpx-bin/httpx-bin.install b/httpx-bin/httpx-bin.install
new file mode 100644
index 0000000..0a0a1ef
--- /dev/null
+++ b/httpx-bin/httpx-bin.install
@@ -0,0 +1,9 @@
1post_upgrade() {
2 cat <<- 'EOF'
3
4The httpx binary has been installed as httpx-toolkit
5Please adjust your workflow accordingly
6This has been done to prevent a name clash with:
7https://archlinux.org/packages/extra/any/python-httpx/
8EOF
9}